summaryrefslogtreecommitdiff
path: root/dev-libs/libucl/libucl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-23 23:40:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-23 23:40:53 +0000
commit8a550e596cf7df735383fc2a2c3b79c51ac0a589 (patch)
tree1c39f7a858fc4a0ee160071ea66cc99c59e30e85 /dev-libs/libucl/libucl-9999.ebuild
parent9aeefa0bd7e7604816f3ce08002112f9965176c3 (diff)
gentoo auto-resync : 23:02:2024 - 23:40:53
Diffstat (limited to 'dev-libs/libucl/libucl-9999.ebuild')
-rw-r--r--dev-libs/libucl/libucl-9999.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-libs/libucl/libucl-9999.ebuild b/dev-libs/libucl/libucl-9999.ebuild
index 8b3e4c0b5cc2..3c35afc0af65 100644
--- a/dev-libs/libucl/libucl-9999.ebuild
+++ b/dev-libs/libucl/libucl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
LUA_COMPAT=( lua5-{1..3} )
inherit lua-single autotools
@@ -18,7 +18,7 @@ else
fi
LICENSE="BSD-2"
-SLOT="0"
+SLOT="0/9"
IUSE="lua +regex sign urls +utils static-libs test"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -36,12 +36,11 @@ RDEPEND="${DEPEND}"
DOCS=( README.md doc/api.md )
pkg_setup() {
- use lua && lua_pkg_setup
+ use lua && lua-single_pkg_setup
}
src_prepare() {
default
- rm tests/schema/{definitions,ref{,Remote}}.json || die
eautoreconf
}
@@ -60,10 +59,6 @@ src_configure() {
econf "${myeconfargs[@]}"
}
-src_test() {
- emake check
-}
-
src_install() {
default
use lua && DOCS+=( "doc/lua_api.md" )