summaryrefslogtreecommitdiff
path: root/dev-libs/libucl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/libucl
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/libucl')
-rw-r--r--dev-libs/libucl/Manifest3
-rw-r--r--dev-libs/libucl/libucl-0.8.1-r100.ebuild71
-rw-r--r--dev-libs/libucl/libucl-9999.ebuild23
3 files changed, 89 insertions, 8 deletions
diff --git a/dev-libs/libucl/Manifest b/dev-libs/libucl/Manifest
index 17f319b52d4a..4353b48aca94 100644
--- a/dev-libs/libucl/Manifest
+++ b/dev-libs/libucl/Manifest
@@ -1,4 +1,5 @@
DIST libucl-0.8.1.tar.gz 2028394 BLAKE2B 18fda317b4b4aed3d6b72c599d191f141bf4722d1c08244deda9c5e77300e2bef7de029889a05d9b4573472928d9d49a797123ac392a4cdd3b690ac277ad673d SHA512 36a059561eadb2dd7253ca22ff56f6a0c6cdd28580e28451c0cf47e1aec321a2e1589fc83ccb2033346f2dbca31a7e6afa9666ea544a0c190b7f80ed0e9f45af
EBUILD libucl-0.8.1-r1.ebuild 1242 BLAKE2B 16135c6e37661c78ccfd62218b3d1ac08f782d6c41e391838c859d563675931297eaedeeec83c1c0c1940dd45b6f2ee5e006c8c073238a3c732a4e1a5eea3d6c SHA512 5247ea70efaed51aa54b3724d92f5ab46a7093db85c1b064b7ef4319b94bbd9454422e777b029bfe75114080d2d5c48fc41b6f4cf773e883bdff9da397bc4164
-EBUILD libucl-9999.ebuild 1242 BLAKE2B 16135c6e37661c78ccfd62218b3d1ac08f782d6c41e391838c859d563675931297eaedeeec83c1c0c1940dd45b6f2ee5e006c8c073238a3c732a4e1a5eea3d6c SHA512 5247ea70efaed51aa54b3724d92f5ab46a7093db85c1b064b7ef4319b94bbd9454422e777b029bfe75114080d2d5c48fc41b6f4cf773e883bdff9da397bc4164
+EBUILD libucl-0.8.1-r100.ebuild 1448 BLAKE2B 7da82d9389bd40244080445583f291882d1e722bb089c9f97642afa76821c046bad7da5f40199a8234bd700e2278d51c6971ed31e72a0fc56789059490bab625 SHA512 0a38bdc4e3118288411b06e63a5ed221581d3c40dfec5da03c402bcb82132470d28e0deff58621455a7787ece53e4ebb4944df4c7de0ad9bd02739969c1e4cf9
+EBUILD libucl-9999.ebuild 1448 BLAKE2B 7da82d9389bd40244080445583f291882d1e722bb089c9f97642afa76821c046bad7da5f40199a8234bd700e2278d51c6971ed31e72a0fc56789059490bab625 SHA512 0a38bdc4e3118288411b06e63a5ed221581d3c40dfec5da03c402bcb82132470d28e0deff58621455a7787ece53e4ebb4944df4c7de0ad9bd02739969c1e4cf9
MISC metadata.xml 955 BLAKE2B 9bcc770371005f7b55c644a987e100572fc6c044ca38a862c817c1fd135864f1ffeb38b3a053a66bb1819ef0dd38f3a27432152779349f7b2af9528448ecfada SHA512 7742b29ef3cd909660e795a35859924f449dc18000ebdfc414e7620b9bf900112dde4ea053648b9490f45a56972a357c5a9645afcdc04211cfb4c3354fd1b8df
diff --git a/dev-libs/libucl/libucl-0.8.1-r100.ebuild b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
new file mode 100644
index 000000000000..66e66cd2dc80
--- /dev/null
+++ b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} )
+inherit lua-single autotools
+
+DESCRIPTION="Universal configuration library parser"
+HOMEPAGE="https://github.com/vstakhov/libucl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vstakhov/libucl.git"
+else
+ SRC_URI="https://github.com/vstakhov/libucl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="lua +regex sign urls +utils static-libs test"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="!!dev-libs/ucl
+ lua? ( ${LUA_DEPS} )
+ urls? ( net-misc/curl )
+ sign? ( dev-libs/openssl:0 )
+"
+BDEPEND="${DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/api.md )
+
+src_prepare() {
+ default
+ rm tests/schema/{definitions,ref{,Remote}}.json || die
+ eautoreconf
+}
+
+src_configure() {
+ lua_setup
+
+ local myeconfargs=(
+ "$(use_enable lua)"
+ "$(use_enable regex)"
+ "$(use_enable sign signatures)"
+ "$(use_enable urls)"
+ "$(use_enable utils)"
+ LUA_INCLUDE="$(lua_get_CFLAGS)"
+ LIB_LIBS="$(lua_get_LIBS)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ use lua && DOCS+=( "doc/lua_api.md" )
+ einstalldocs
+ if ! use static-libs; then
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || \
+ die "error while deleting static library"
+ fi
+}
diff --git a/dev-libs/libucl/libucl-9999.ebuild b/dev-libs/libucl/libucl-9999.ebuild
index c4c4911fe043..66e66cd2dc80 100644
--- a/dev-libs/libucl/libucl-9999.ebuild
+++ b/dev-libs/libucl/libucl-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit autotools
+LUA_COMPAT=( lua5-{1..3} )
+inherit lua-single autotools
DESCRIPTION="Universal configuration library parser"
HOMEPAGE="https://github.com/vstakhov/libucl"
@@ -18,11 +19,12 @@ fi
LICENSE="BSD-2"
SLOT="0"
-
-IUSE="lua +regex sign urls +utils static-libs"
+IUSE="lua +regex sign urls +utils static-libs test"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
DEPEND="!!dev-libs/ucl
- lua? ( >=dev-lang/lua-5.1:= )
+ lua? ( ${LUA_DEPS} )
urls? ( net-misc/curl )
sign? ( dev-libs/openssl:0 )
"
@@ -36,24 +38,31 @@ DOCS=( README.md doc/api.md )
src_prepare() {
default
rm tests/schema/{definitions,ref{,Remote}}.json || die
-
eautoreconf
}
src_configure() {
+ lua_setup
+
local myeconfargs=(
"$(use_enable lua)"
"$(use_enable regex)"
"$(use_enable sign signatures)"
"$(use_enable urls)"
"$(use_enable utils)"
+ LUA_INCLUDE="$(lua_get_CFLAGS)"
+ LIB_LIBS="$(lua_get_LIBS)"
)
- econf "${myeconfargs}"
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake check
}
src_install() {
default
- DOCS+=( $(usex lua "doc/lua_api.md" "") )
+ use lua && DOCS+=( "doc/lua_api.md" )
einstalldocs
if ! use static-libs; then
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || \