summaryrefslogtreecommitdiff
path: root/dev-libs/libunibreak/libunibreak-5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 11:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 11:41:01 +0100
commit7a58deff37cc7d12967dc30f49192d16cd110ee4 (patch)
treeca65be9cbb8367aaf04ffc7525fe5ca12fc7ead9 /dev-libs/libunibreak/libunibreak-5.1.ebuild
parent4ae313835e5a6ac84a7fd1131b0c51c7a0759626 (diff)
gentoo auto-resync : 09:05:2023 - 11:41:00
Diffstat (limited to 'dev-libs/libunibreak/libunibreak-5.1.ebuild')
-rw-r--r--dev-libs/libunibreak/libunibreak-5.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libunibreak/libunibreak-5.1.ebuild b/dev-libs/libunibreak/libunibreak-5.1.ebuild
new file mode 100644
index 000000000000..ee39d6ae81d0
--- /dev/null
+++ b/dev-libs/libunibreak/libunibreak-5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Line and word breaking library"
+HOMEPAGE="http://vimgadgets.sourceforge.net/libunibreak/"
+SRC_URI="https://github.com/adah1972/${PN}/releases/download/${PN}_$(ver_rs 1- '_')/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc +man static-libs"
+
+# Tests require internet access to www.unicode.org
+RESTRICT="test"
+
+BDEPEND="man? ( app-doc/doxygen )"
+
+src_prepare() {
+ if use man; then
+ echo 'GENERATE_MAN=YES' >> Doxyfile || die
+ echo 'GENERATE_HTML=NO' >> Doxyfile || die
+ fi
+ default
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ if use man; then
+ doxygen || die 'doxygen failed'
+ pushd "${S}"/doc/man > /dev/null
+ mv man3 x || die
+ mkdir man3 || die
+ for h in graphemebreak linebreak linebreakdef unibreakbase unibreakdef wordbreak; do
+ mv x/${h}.h.3 man3/ || die "man ${h} not found"
+ done
+ rm -rf x || die
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -delete || die
+ if use man; then
+ doman doc/man/man3/*.3
+ fi
+}