summaryrefslogtreecommitdiff
path: root/dev-libs/libx86emu/libx86emu-3.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-27 23:32:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-27 23:32:51 +0100
commit881ed853a610750628d101d50410e9f3bf370d87 (patch)
tree1e83f90631d71c2e2b0376bb0e725f49ede671da /dev-libs/libx86emu/libx86emu-3.5-r1.ebuild
parent5b4dc9f80a36fa17a541592b7bd29d31418e6a7b (diff)
gentoo auto-resync : 27:09:2023 - 23:32:51
Diffstat (limited to 'dev-libs/libx86emu/libx86emu-3.5-r1.ebuild')
-rw-r--r--dev-libs/libx86emu/libx86emu-3.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libx86emu/libx86emu-3.5-r1.ebuild b/dev-libs/libx86emu/libx86emu-3.5-r1.ebuild
new file mode 100644
index 000000000000..339ae9ee5072
--- /dev/null
+++ b/dev-libs/libx86emu/libx86emu-3.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A library for emulating x86"
+HOMEPAGE="https://github.com/wfeldt/libx86emu"
+SRC_URI="https://github.com/wfeldt/libx86emu/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ echo "${PV}" > VERSION || die
+ rm -fr git2log || die
+}
+
+src_compile() {
+ emake shared CC=$(tc-getCC) CFLAGS="${CFLAGS} -fPIC -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ emake test CC=$(tc-getCC) CFLAGS="${CFLAGS} -fPIC -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc README.md
+}