summaryrefslogtreecommitdiff
path: root/dev-libs/libxml2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
commit996a2bda06cb164877d5d952774a6db1b271c2f3 (patch)
tree31930352b48fc7622d658ae37658c57ad9511ef6 /dev-libs/libxml2
parent67e5603b2844a6657dd0438fa26626b013e5567f (diff)
gentoo auto-resync : 25:06:2024 - 00:12:20
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/Manifest2
-rw-r--r--dev-libs/libxml2/libxml2-9999.ebuild13
2 files changed, 3 insertions, 12 deletions
diff --git a/dev-libs/libxml2/Manifest b/dev-libs/libxml2/Manifest
index d66253c2e145..181eff9a014d 100644
--- a/dev-libs/libxml2/Manifest
+++ b/dev-libs/libxml2/Manifest
@@ -14,5 +14,5 @@ EBUILD libxml2-2.12.5.ebuild 5248 BLAKE2B 5bfa07ebbef8b985c246b28b9d56dcca2f9cbd
EBUILD libxml2-2.12.6.ebuild 5248 BLAKE2B 5bfa07ebbef8b985c246b28b9d56dcca2f9cbd881a7933dcc29fea023ed850c9d3630611651b0214f59f2b7ddb6dc0759f37f72c34a09e429e8b7284d339051a SHA512 53766010d7b0f9d9bbd35b9c3df96f777c44b2d003cba8a3d17d075c0fc0ddc7347688980ec597c11623156544896fc4e64870dec56b625a1c36eacdc2a40a0c
EBUILD libxml2-2.12.7.ebuild 5256 BLAKE2B 8e512b8c1bff1c1799f73004a96bacab4679bd3d1dde1f50adb23bac04c49718946d9dc4f5b07182a6b920a2a07257b1692d990cfb5a0608bc71f0fe4ed7a693 SHA512 26894b5fd0dc9a8f5afb162373aaff979ad2901ee9912d869773035082a7b337efe9fe034732009a4326bcbad4e5a0f9048792b0fafd9d7fb3bbc5ed4b393cbd
EBUILD libxml2-2.12.8.ebuild 5256 BLAKE2B 8e512b8c1bff1c1799f73004a96bacab4679bd3d1dde1f50adb23bac04c49718946d9dc4f5b07182a6b920a2a07257b1692d990cfb5a0608bc71f0fe4ed7a693 SHA512 26894b5fd0dc9a8f5afb162373aaff979ad2901ee9912d869773035082a7b337efe9fe034732009a4326bcbad4e5a0f9048792b0fafd9d7fb3bbc5ed4b393cbd
-EBUILD libxml2-9999.ebuild 5256 BLAKE2B 8e512b8c1bff1c1799f73004a96bacab4679bd3d1dde1f50adb23bac04c49718946d9dc4f5b07182a6b920a2a07257b1692d990cfb5a0608bc71f0fe4ed7a693 SHA512 26894b5fd0dc9a8f5afb162373aaff979ad2901ee9912d869773035082a7b337efe9fe034732009a4326bcbad4e5a0f9048792b0fafd9d7fb3bbc5ed4b393cbd
+EBUILD libxml2-9999.ebuild 4906 BLAKE2B 61247853a173e8294c8a6c33dab565acdf761693d9cf098aae9364d11db17168386c84a2e9649b1f140912d1d75c7c9b8abb999097a0a926c267eb61039e46d1 SHA512 184005fcf8fb255e04fdf006b49f4a736dccef59e39adc986de04b133b85cdc69bd1e51acc15ff9cdb30d52195dc55d684676eb1a41d23184582e3486281a1d4
MISC metadata.xml 519 BLAKE2B 528be4ec79b54eaed229c84c96656266acffaa2ab68c7b1e6daecdee77bb1109ea56babceff0459125e04326425be28f436a78f697c363920102b94aca25179d SHA512 85804c662dd019e6c4cad05bb691b2058c9b93c190c57a7b4cc2674bee71a805da41159184c1bae9954700e52b41bb104a2d1e66ea4d1799463626befb691d11
diff --git a/dev-libs/libxml2/libxml2-9999.ebuild b/dev-libs/libxml2/libxml2-9999.ebuild
index c4d87530a6d4..e3b042b80914 100644
--- a/dev-libs/libxml2/libxml2-9999.ebuild
+++ b/dev-libs/libxml2/libxml2-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
-inherit flag-o-matic python-r1 multilib-minimal
+inherit python-r1 multilib-minimal
XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
XSTS_NAME_1="xmlschema2002-01-16"
@@ -37,7 +37,7 @@ S="${WORKDIR}/${PN}-${PV%_rc*}"
LICENSE="MIT"
SLOT="2"
-IUSE="debug examples +ftp icu lzma +python readline static-libs test"
+IUSE="examples icu lzma +python readline static-libs test"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -99,17 +99,8 @@ src_prepare() {
}
multilib_src_configure() {
- # Filter seemingly problematic CFLAGS (bug #26320)
- filter-flags -fprefetch-loop-arrays -funroll-loops
-
- # Notes:
- # The meaning of the 'debug' USE flag does not apply to the --with-debug
- # switch (enabling the libxml2 debug module). See bug #100898.
libxml2_configure() {
ECONF_SOURCE="${S}" econf \
- --enable-ipv6 \
- $(use_with ftp) \
- $(use_with debug run-debug) \
$(use_with icu) \
$(use_with lzma) \
$(use_enable static-libs static) \