summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
commit2de9aaae9b6018544ada7f67e2229605e1ec4d04 (patch)
tree231bad5690196ca522285d446614a065879cc7d0 /dev-libs/mimalloc/mimalloc-2.1.1.ebuild
parent4274bed0c1f1fd06a654f5816e30d82059f4cc39 (diff)
gentoo auto-resync : 05:04:2023 - 23:26:20
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.1.1.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.1.1.ebuild b/dev-libs/mimalloc/mimalloc-2.1.1.ebuild
new file mode 100644
index 000000000000..5c8b6056d6ae
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="hardened test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}