summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 12:57:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 12:57:49 +0000
commitb2f1788f6f0365b76f55f257b2d170c1e68a8640 (patch)
tree508984ca9480c5d791a38bcd454c260752330cfb /dev-libs/mimalloc
parent16fa78787149cbbd73549c6bcda0eec50293ea0e (diff)
gentoo auto-resync : 29:01:2024 - 12:57:49
Diffstat (limited to 'dev-libs/mimalloc')
-rw-r--r--dev-libs/mimalloc/Manifest2
-rw-r--r--dev-libs/mimalloc/mimalloc-2.1.2.ebuild5
2 files changed, 5 insertions, 2 deletions
diff --git a/dev-libs/mimalloc/Manifest b/dev-libs/mimalloc/Manifest
index 4e931a8a2caa..fe626b36532d 100644
--- a/dev-libs/mimalloc/Manifest
+++ b/dev-libs/mimalloc/Manifest
@@ -1,3 +1,3 @@
DIST mimalloc-2.1.2.tar.gz 1163868 BLAKE2B bba29671fdca81b682edeefe16a1239640ea28fee4e44c97d0422ae81e0b3e7141c733459ccafc6672780157af67ff7d2a10cf4157180e003b458332a79d8481 SHA512 927b046e67783b325a6e41e3a9a6d3d78306fa1c82255defd1f3a7a60a27fd809a601f65b1b27fa38f2064e124f29856d7c0e5ccc33c54c2e4b6ebb9816d74b1
-EBUILD mimalloc-2.1.2.ebuild 800 BLAKE2B f7ef71d11a700b8abed6a70609a11f2f1742f7bfd6801b7843f199a8654225e5f18da0d300c9f07cfe268099957b3f4a69095cc8ffc542794f3fc1e5c36d9989 SHA512 63ab08046efafa32a4d532bf66ad1d321db78f4153686057e8bb7f100b6f6cf818aade8f54253abcdd43d6858ef0b7dbac9594f05c980bc8b737252610a979fc
+EBUILD mimalloc-2.1.2.ebuild 850 BLAKE2B df1b87e00239d319dd692395fe31c6376fb2e197208a002234cb6f62a2f43429fb0e7a90b0ba308a880e7dcfb343caa716d2bad7b2add0a9e7c9a49ff1741ae1 SHA512 847340d9b4a95d81fc7a5fe99b724cacd1eb96cd794f67ca934a7af32e1cfc11c3f8a58d0cd3403e9155b0d74150962d6971bcaa8f2c0dbaa998bf7a5fb02dbc
MISC metadata.xml 504 BLAKE2B cf6477282968a5469d072cfd81ce800e3ef0a48deb5353c85a1cabc837560cafdb9f9739cb4e98784238d2cc512a29cae5efee401f92a19bf75fb5d810154f76 SHA512 4e8fcc49881f3c479424cf363665d9b12c58eb52f7d962b98b81f5b3e186ba3bd14c2b5dac488d819147121a16c2d9613e75cb77f71fa04e820ca2c1e538baa6
diff --git a/dev-libs/mimalloc/mimalloc-2.1.2.ebuild b/dev-libs/mimalloc/mimalloc-2.1.2.ebuild
index dcc758662a5f..82790836bf71 100644
--- a/dev-libs/mimalloc/mimalloc-2.1.2.ebuild
+++ b/dev-libs/mimalloc/mimalloc-2.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="A compact general purpose allocator with excellent performance"
HOMEPAGE="https://github.com/microsoft/mimalloc"
@@ -18,6 +18,9 @@ RESTRICT="!test? ( test )"
DEPEND="valgrind? ( dev-debug/valgrind )"
src_configure() {
+ # Bug #923177
+ append-atomic-flags
+
local mycmakeargs=(
-DMI_SECURE=$(usex hardened)
-DMI_INSTALL_TOPLEVEL=ON