summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-libs/mongo-c-driver/files
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-libs/mongo-c-driver/files')
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.11.0-enable-tests.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.11.0-enable-tests.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.11.0-enable-tests.patch
new file mode 100644
index 000000000000..67fafafc93b2
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.11.0-enable-tests.patch
@@ -0,0 +1,25 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 860e4ea..7d646b1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -110,7 +110,6 @@ if (ENABLE_BSON STREQUAL SYSTEM)
+ message ("-- libbson include path \"${BSON_INCLUDE_DIRS}\"")
+ message ("-- libbson libraries \"${BSON_LIBRARIES}\"")
+ message ("-- disabling test-libmongoc since using system libbson")
+- SET (ENABLE_TESTS OFF)
+
+ if (ENABLE_STATIC MATCHES "ON|AUTO")
+ find_package (libbson-static-1.0
+diff --git a/src/libbson/tests/test-bson.c b/src/libbson/tests/test-bson.c
+index 51514ed..accb251 100644
+--- a/src/libbson/tests/test-bson.c
++++ b/src/libbson/tests/test-bson.c
+@@ -18,7 +18,7 @@
+ #include <bson.h>
+ #include <bcon.h>
+ #define BSON_INSIDE
+-#include <bson-private.h>
++#include "bson-private.h"
+ #undef BSON_INSIDE
+ #include <fcntl.h>
+ #include <time.h>