summaryrefslogtreecommitdiff
path: root/dev-libs/newt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/newt/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/newt/files')
-rw-r--r--dev-libs/newt/files/newt-0.52.13-gold.patch12
-rw-r--r--dev-libs/newt/files/newt-0.52.14-tcl.patch108
-rw-r--r--dev-libs/newt/files/newt-0.52.15-makefile.patch13
-rw-r--r--dev-libs/newt/files/newt-0.52.15-snack.patch13
4 files changed, 146 insertions, 0 deletions
diff --git a/dev-libs/newt/files/newt-0.52.13-gold.patch b/dev-libs/newt/files/newt-0.52.13-gold.patch
new file mode 100644
index 000000000000..91626c6306e8
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.13-gold.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,7 +19,8 @@
+ AC_MSG_CHECKING([for GNU ld])
+ LD=`$CC -print-prog-name=ld 2>&5`
+
+-if test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld"` = 0; then
++if test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld"` = 0 -a \
++ test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU gold"` = 0; then
+ # Not
+ GNU_LD=""
+ AC_MSG_RESULT([no])
diff --git a/dev-libs/newt/files/newt-0.52.14-tcl.patch b/dev-libs/newt/files/newt-0.52.14-tcl.patch
new file mode 100644
index 000000000000..4e10d2baae9e
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.14-tcl.patch
@@ -0,0 +1,108 @@
+diff --git a/whiptcl.c b/whiptcl.c
+index 8688780..7219911 100644
+--- a/whiptcl.c
++++ b/whiptcl.c
+@@ -137,45 +137,45 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+
+ if (arg < -1) {
+ /* this could buffer oveflow, bug we're not setuid so I don't care */
+- interp->result = malloc(200);
+- interp->freeProc = TCL_DYNAMIC;
+- sprintf(interp->result, "%s: %s\n",
++ char *tmp = malloc(200);
++ sprintf(tmp, "%s: %s\n",
+ poptBadOption(optCon, POPT_BADOPTION_NOALIAS),
+ poptStrerror(arg));
++ Tcl_SetResult(interp, tmp, TCL_DYNAMIC);
+
+ return TCL_ERROR;
+ }
+
+ if (mode == MODE_NONE) {
+- interp->result = "no dialog mode was specified";
++ Tcl_SetResultString(interp, "no dialog mode was specified");
+ return TCL_ERROR;
+ } else if (rc) {
+- interp->result = "multiple modes were specified";
++ Tcl_SetResultString(interp, "multiple modes were specified");
+ return TCL_ERROR;
+ }
+
+ if (!(text = poptGetArg(optCon))) {
+- interp->result = "missing text parameter";
++ Tcl_SetResultString(interp, "missing text parameter");
+ return TCL_ERROR;
+ }
+
+ if (!(nextArg = poptGetArg(optCon))) {
+- interp->result = "height missing";
++ Tcl_SetResultString(interp, "height missing");
+ return TCL_ERROR;
+ }
+ height = strtoul(nextArg, &end, 10);
+ if (*end) {
+- interp->result = "height is not a number";
++ Tcl_SetResultString(interp, "height is not a number");
+ return TCL_ERROR;
+ }
+
+ if (!(nextArg = poptGetArg(optCon))) {
+- interp->result = "width missing";
++ Tcl_SetResultString(interp, "width missing");
+ return TCL_ERROR;
+ }
+ width = strtoul(nextArg, &end, 10);
+ if (*end) {
+- interp->result = "width is not a number";
++ Tcl_SetResultString(interp, "width is not a number");
+ return TCL_ERROR;
+ }
+
+@@ -196,33 +196,30 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+ case MODE_YESNO:
+ rc = messageBox(text, height, width, MSGBOX_YESNO, flags);
+ if (rc == DLG_OKAY)
+- interp->result = "yes";
++ Tcl_SetResultString(interp, "yes");
+ else
+- interp->result = "no";
++ Tcl_SetResultString(interp, "no");
+ if (rc == DLG_ERROR) rc = 0;
+ break;
+
+ case MODE_INPUTBOX:
+ rc = inputBox(text, height, width, optCon, flags, &result);
+ if (rc ==DLG_OKAY) {
+- interp->result = result;
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, result, TCL_DYNAMIC);
+ }
+ break;
+
+ case MODE_MENU:
+ rc = listBox(text, height, width, optCon, flags, default_item, &result);
+ if (rc==DLG_OKAY) {
+- interp->result = result;
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, result, TCL_DYNAMIC);
+ }
+ break;
+
+ case MODE_RADIOLIST:
+ rc = checkList(text, height, width, optCon, 1, flags, &selections);
+ if (rc==DLG_OKAY) {
+- interp->result = selections[0];
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, selections[0], TCL_DYNAMIC);
+
+ free(selections);
+ }
+@@ -247,7 +244,7 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+ newtPopWindow();
+
+ if (rc == DLG_ERROR) {
+- interp->result = "bad paramter for whiptcl dialog box";
++ Tcl_SetResultString(interp, "bad paramter for whiptcl dialog box");
+ return TCL_ERROR;
+ }
+
diff --git a/dev-libs/newt/files/newt-0.52.15-makefile.patch b/dev-libs/newt/files/newt-0.52.15-makefile.patch
new file mode 100644
index 000000000000..55812bf10460
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.15-makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 4ae284b..cd5c4a7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -127,7 +127,7 @@ $(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
+ ln -fs $(LIBNEWTSONAME) libnewt.so
+ ln -fs $(LIBNEWTSH) $(LIBNEWTSONAME)
+
+-$(SHAREDDIR)/%.o : %.c
++$(SHAREDDIR)/%.o : %.c $(SHAREDDIR)
+ $(CC) $(SHCFLAGS) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+
+ install: $(LIBNEWT) install-sh whiptail
diff --git a/dev-libs/newt/files/newt-0.52.15-snack.patch b/dev-libs/newt/files/newt-0.52.15-snack.patch
new file mode 100644
index 000000000000..dd2627538e6d
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.15-snack.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 75764e1..ca95bb6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -90,7 +90,7 @@ _snackmodule.so: snackmodule.c $(LIBNEWTSH)
+ PLDFLAGS=`$$pyconfig --ldflags`; \
+ PLFLAGS=`$$pyconfig --libs`; \
+ echo $(CC) $(SHCFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c; \
+- $(CC) $(SHCFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c; \
++ $(CC) $(SHCFLAGS) $(CFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c; \
+ echo $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS); \
+ $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS); \
+ done || :