summaryrefslogtreecommitdiff
path: root/dev-libs/nsgenbind/nsgenbind-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 14:07:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 14:07:55 +0000
commitd725480af7cbc67d784e5d96f973fa41e9030123 (patch)
tree620bbc21e2e1384f13394c32a7294bc1c0e8bae1 /dev-libs/nsgenbind/nsgenbind-0.9.ebuild
parent0184387f6a748c74c5d29cddf20289dc94f05ddc (diff)
gentoo auto-resync : 19:01:2024 - 14:07:55
Diffstat (limited to 'dev-libs/nsgenbind/nsgenbind-0.9.ebuild')
-rw-r--r--dev-libs/nsgenbind/nsgenbind-0.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/nsgenbind/nsgenbind-0.9.ebuild b/dev-libs/nsgenbind/nsgenbind-0.9.ebuild
new file mode 100644
index 000000000000..a4287e01910f
--- /dev/null
+++ b/dev-libs/nsgenbind/nsgenbind-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit netsurf
+
+DESCRIPTION="Generate Javascript-to-DOM bindings from w3c webidl files"
+HOMEPAGE="http://www.netsurf-browser.org/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-build/netsurf-buildsystem
+ app-alternatives/yacc"
+
+_emake() {
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=binary $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}