summaryrefslogtreecommitdiff
path: root/dev-libs/olm/olm-3.2.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
commit4482d99f0743195c71b2b03faa8bfbda5501910b (patch)
tree853f042c5e26ca4bce5b091ccc3128b9a763984a /dev-libs/olm/olm-3.2.16.ebuild
parent9c4ecbcb1ba97e8bfd6dac8c2433fb9fdfee5fe6 (diff)
gentoo auto-resync : 27:01:2024 - 12:56:47
Diffstat (limited to 'dev-libs/olm/olm-3.2.16.ebuild')
-rw-r--r--dev-libs/olm/olm-3.2.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/olm/olm-3.2.16.ebuild b/dev-libs/olm/olm-3.2.16.ebuild
new file mode 100644
index 000000000000..8478830343a0
--- /dev/null
+++ b/dev-libs/olm/olm-3.2.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
+SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) # TODO: upstream
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}