summaryrefslogtreecommitdiff
path: root/dev-libs/opensc/opensc-0.23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
commita407e25d814596ca802d83102671d95e00079767 (patch)
treeb0d4824cf74ddca3ee380c618ffae855cd0d1bcd /dev-libs/opensc/opensc-0.23.0.ebuild
parent441510fa20665b7920b149994e72b3a1cd62a813 (diff)
gentoo auto-resync : 31:05:2023 - 15:23:38
Diffstat (limited to 'dev-libs/opensc/opensc-0.23.0.ebuild')
-rw-r--r--dev-libs/opensc/opensc-0.23.0.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-libs/opensc/opensc-0.23.0.ebuild b/dev-libs/opensc/opensc-0.23.0.ebuild
index b46faccba7b9..5e6d2db59ebf 100644
--- a/dev-libs/opensc/opensc-0.23.0.ebuild
+++ b/dev-libs/opensc/opensc-0.23.0.ebuild
@@ -7,11 +7,17 @@ inherit bash-completion-r1 libtool
DESCRIPTION="Libraries and applications to access smartcards"
HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
-SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/OpenSC/OpenSC.git"
+else
+ SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 ppc64 x86"
+fi
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 ppc64 x86"
IUSE="ctapi doc openct notify pace +pcsc-lite readline secure-messaging ssl test zlib"
RESTRICT="!test? ( test )"
@@ -36,7 +42,12 @@ REQUIRED_USE="
src_prepare() {
default
- elibtoolize
+
+ if [[ ${PV} == *9999 ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_configure() {