summaryrefslogtreecommitdiff
path: root/dev-libs/opensc/opensc-0.23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 15:05:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 15:05:02 +0000
commite523ebcd50638ebe53f8f425d126bfa7385703b5 (patch)
treea8202f9224bd577afe09c919786f8836cf4a2a7c /dev-libs/opensc/opensc-0.23.0.ebuild
parentd88834e7a12432c4e2d04ca7e938a66e25811f89 (diff)
gentoo auto-resync : 01:02:2023 - 15:05:01
Diffstat (limited to 'dev-libs/opensc/opensc-0.23.0.ebuild')
-rw-r--r--dev-libs/opensc/opensc-0.23.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/opensc/opensc-0.23.0.ebuild b/dev-libs/opensc/opensc-0.23.0.ebuild
new file mode 100644
index 000000000000..1a356b477973
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.23.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 libtool
+
+DESCRIPTION="Libraries and applications to access smartcards"
+HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
+SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="ctapi doc openct openpace notify +pcsc-lite readline secure-messaging ssl test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ openpace? ( dev-libs/openpace:= )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ notify? ( dev-libs/glib:2 )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="
+ pcsc-lite? ( !openct !ctapi )
+ openct? ( !pcsc-lite !ctapi )
+ ctapi? ( !pcsc-lite !openct )
+ || ( pcsc-lite openct ctapi )"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ # don't want to run upstream's clang-tidy checks
+ export ac_cv_path_CLANGTIDY=""
+
+ econf \
+ --with-completiondir="$(get_bashcompdir)" \
+ --disable-strict \
+ --enable-man \
+ $(use_enable ctapi) \
+ $(use_enable doc) \
+ $(use_enable notify ) \
+ $(use_enable openct) \
+ $(use_enable openpace ) \
+ $(use_enable pcsc-lite pcsc) \
+ $(use_enable readline) \
+ $(use_enable secure-messaging sm) \
+ $(use_enable ssl openssl) \
+ $(use_enable test cmocka) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+
+ insinto /etc/pkcs11/modules/
+ doins "${FILESDIR}"/opensc.module
+
+ find "${ED}" -name '*.la' -delete || die
+}