summaryrefslogtreecommitdiff
path: root/dev-libs/opensc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-28 02:00:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-28 02:00:16 +0000
commita2148b9fab4c83209816a49f091d70873b19881d (patch)
treeaeeaea24918f3a0df7fc0e4e013c68df40469897 /dev-libs/opensc
parentead7697a01fd631b56240b2d58aedd98ba7f92d3 (diff)
gentoo auto-resync : 28:11:2024 - 02:00:16
Diffstat (limited to 'dev-libs/opensc')
-rw-r--r--dev-libs/opensc/Manifest4
-rw-r--r--dev-libs/opensc/opensc-0.26.0.ebuild87
-rw-r--r--dev-libs/opensc/opensc-9999.ebuild4
3 files changed, 92 insertions, 3 deletions
diff --git a/dev-libs/opensc/Manifest b/dev-libs/opensc/Manifest
index 910e2cd123ea..3446f232fe5b 100644
--- a/dev-libs/opensc/Manifest
+++ b/dev-libs/opensc/Manifest
@@ -1,5 +1,7 @@
AUX opensc.module 390 BLAKE2B 4c5ea159ed2038af51c9ca3e903b23db1acdfa8a6c79be7f922f8a03602f15e3b1a98570be0a1f3f2db922c9083976eeb164d011b981c8709a9b1459e959634f SHA512 52a0a47963d0938a3a644dedcd913bb22ea6d5e3d539b759872c4175085491cc11a3958bb308029eb4942ea20e0f7890865c21cb063e335e38a154957a64ed58
DIST opensc-0.25.1.tar.gz 2395579 BLAKE2B cc7994cad78083c8eeafc947e90c06178209edc825cb14b54bc4281d37c6dae1006ab2c9b9566823ef90626a4134bce96a9806bebc455a389216d7953da6b873 SHA512 6277abb31f903af68b4c19f549fc881b69d7aa9a55ba39936386118eadde86b62853ba2906cd165d9b1ad9090e1aa4d2b236bf19650aa228ed776b3f4d9f8805
+DIST opensc-0.26.0.tar.gz 2415271 BLAKE2B c1fb4f961797291fd9d36eb7b5a58a74c1d5a71c2313813cc715115ccf7a7279f6820b99cb1490daa0287c5d45175f6164e5fc7215fa46ebe5d043556f4ebd31 SHA512 99d88e6f83eb8b6d349bd88d51df652bc44973ac9397d516ad503c256d664a842698093b4e50e0877ece5f05151b5575fc39220620c82c7a000c971f8c98449f
EBUILD opensc-0.25.1.ebuild 2260 BLAKE2B ae5b979df3f024aee666d645be7f3af8a11d2d183530401f5423287735e9c9cb55b12df478fa05a8322e1bfcd90180a47cc73635dc4bffd2c27eb96a44ef0a5d SHA512 697e5e8cfb96779e32db894a35cedf4ebfc9518be6232ed1b6a732e36bb5803081d6f3b214b209df6553f99505c1a2ddeb07f04faf176aa5b654b658f4c3c0bd
-EBUILD opensc-9999.ebuild 2260 BLAKE2B eb266c34a9f9221956f70eaa3b4b3e6d8c6fc4ecaadd7f8e80e8bb57bbb9c1916b7e564d37fa3955a5292e7edbe56951cda80187af0cfdf8b1a4ab014362d409 SHA512 8cee8cc32dbf89dd760afdf9337ec2a3d6ae90fd145a53e2196947757824a7c54d7bf631c01f71dbe2cfc9f1f1e374224ead4bed6f9b545e4e033bc9805d077a
+EBUILD opensc-0.26.0.ebuild 2272 BLAKE2B 510c29f75565053b6c3ecee1676088921bc896430a9c62d4f8ab1c21b31b930145b22d79f1740490f0dba5107a55a881efbe65726c020a570c296906d6666119 SHA512 b0c317b2d9b76e3189a429f8a83db37d200cf3e94d0d5c59e6eeaf028c1554c49638f1d42bb59847f8711f4a15aa8882d2b502c2dbe22e12fe9d07df2c25ed77
+EBUILD opensc-9999.ebuild 2272 BLAKE2B 510c29f75565053b6c3ecee1676088921bc896430a9c62d4f8ab1c21b31b930145b22d79f1740490f0dba5107a55a881efbe65726c020a570c296906d6666119 SHA512 b0c317b2d9b76e3189a429f8a83db37d200cf3e94d0d5c59e6eeaf028c1554c49638f1d42bb59847f8711f4a15aa8882d2b502c2dbe22e12fe9d07df2c25ed77
MISC metadata.xml 1305 BLAKE2B 8560829a2784e38e10b41f5e083568a7fafd19e9fe185b1675c787b2514ea01a18b3fa6c7d0018b6e45638512d02e9bec12fbc5df4e50bf49db6558ef89a9af8 SHA512 8b477d96f6acb7a808e24af1d4b29e16e06b83eaf29799dbc6b74181ded74de47d7527712e21412bfb92a26e1d03974368a2c1790208785230280a18d21aff06
diff --git a/dev-libs/opensc/opensc-0.26.0.ebuild b/dev-libs/opensc/opensc-0.26.0.ebuild
new file mode 100644
index 000000000000..42544e82ef41
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.26.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="Libraries and applications to access smartcards"
+HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenSC/OpenSC.git"
+else
+ SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ BSD"
+SLOT="0/11"
+IUSE="ctapi doc openct notify pace +pcsc-lite readline secure-messaging ssl test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ pace? ( dev-libs/openpace:= )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ notify? ( dev-libs/glib:2 )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ test? (
+ dev-util/cmocka
+ dev-libs/softhsm
+ )"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="
+ pcsc-lite? ( !openct !ctapi )
+ openct? ( !pcsc-lite !ctapi )
+ ctapi? ( !pcsc-lite !openct )
+ || ( pcsc-lite openct ctapi )"
+
+src_prepare() {
+ # This test is known to fail, for a long time upstream has carried
+ # version-specific patches which they would update on every version bump.
+ # There doesn't appear to be a permanent solution yet.
+ sed -i "/test-pkcs11-tool-unwrap-wrap-test.sh/d" "tests/Makefile.am" || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # don't want to run upstream's clang-tidy checks
+ export ac_cv_path_CLANGTIDY=""
+
+ econf \
+ --with-completiondir="$(get_bashcompdir)" \
+ --disable-strict \
+ --enable-man \
+ $(use_enable ctapi) \
+ $(use_enable doc) \
+ $(use_enable notify) \
+ $(use_enable openct) \
+ $(use_enable pace openpace) \
+ $(use_enable pcsc-lite pcsc) \
+ $(use_enable readline) \
+ $(use_enable secure-messaging sm) \
+ $(use_enable ssl openssl) \
+ $(use_enable test cmocka) \
+ $(use_enable zlib)
+}
+
+src_test() {
+ P11LIB="${ESYSROOT}/usr/$(get_libdir)/softhsm/libsofthsm2.so" default
+}
+
+src_install() {
+ default
+
+ insinto /etc/pkcs11/modules/
+ doins "${FILESDIR}"/opensc.module
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/opensc/opensc-9999.ebuild b/dev-libs/opensc/opensc-9999.ebuild
index 874286524ce2..42544e82ef41 100644
--- a/dev-libs/opensc/opensc-9999.ebuild
+++ b/dev-libs/opensc/opensc-9999.ebuild
@@ -13,10 +13,10 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/OpenSC/OpenSC.git"
else
SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+ BSD"
SLOT="0/11"
IUSE="ctapi doc openct notify pace +pcsc-lite readline secure-messaging ssl test zlib"
RESTRICT="!test? ( test )"