summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild')
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild b/dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild
new file mode 100644
index 000000000000..00dcc508cf72
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-1.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-multilib
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Protocol Buffers implementation in C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="static-libs test"
+
+RDEPEND=">=dev-libs/protobuf-2.6.0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( ${AUTOTOOLS_DEPEND} )
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use test ; then
+ epatch "${FILESDIR}"/${PN}-1.1.0-no-build-tests.patch
+ AUTOTOOLS_AUTORECONF=true
+ fi
+ autotools-multilib_src_prepare
+}