summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/protobuf/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/protobuf/files')
-rw-r--r--dev-libs/protobuf/files/protobuf-3.15.0-disable_no-warning-test.patch (renamed from dev-libs/protobuf/files/protobuf-3.12.0-disable_no-warning-test.patch)4
-rw-r--r--dev-libs/protobuf/files/protobuf-3.15.0-protoc_input_output_files.patch (renamed from dev-libs/protobuf/files/protobuf-3.12.0-protoc_input_output_files.patch)136
-rw-r--r--dev-libs/protobuf/files/protobuf-3.15.0-system_libraries.patch (renamed from dev-libs/protobuf/files/protobuf-3.12.0-system_libraries.patch)10
3 files changed, 64 insertions, 86 deletions
diff --git a/dev-libs/protobuf/files/protobuf-3.12.0-disable_no-warning-test.patch b/dev-libs/protobuf/files/protobuf-3.15.0-disable_no-warning-test.patch
index d7dd5b5b1bb9..031b1b222a9e 100644
--- a/dev-libs/protobuf/files/protobuf-3.12.0-disable_no-warning-test.patch
+++ b/dev-libs/protobuf/files/protobuf-3.15.0-disable_no-warning-test.patch
@@ -2,7 +2,7 @@ Disable no-warning-test which is compiled with -Werror option and whose only pur
--- /src/Makefile.am
+++ /src/Makefile.am
-@@ -717,7 +717,7 @@
+@@ -709,7 +709,7 @@
GOOGLEMOCK_SRC_DIR=$(srcdir)/../third_party/googletest/googlemock
check_PROGRAMS = protoc protobuf-test protobuf-lazy-descriptor-test \
protobuf-lite-test test_plugin protobuf-lite-arena-test \
@@ -11,7 +11,7 @@ Disable no-warning-test which is compiled with -Werror option and whose only pur
protobuf_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
$(GOOGLETEST_BUILD_DIR)/lib/libgtest.la \
$(GOOGLEMOCK_BUILD_DIR)/lib/libgmock.la \
-@@ -904,4 +904,4 @@
+@@ -896,4 +896,4 @@
TESTS = protobuf-test protobuf-lazy-descriptor-test protobuf-lite-test \
google/protobuf/compiler/zip_output_unittest.sh $(GZTESTS) \
diff --git a/dev-libs/protobuf/files/protobuf-3.12.0-protoc_input_output_files.patch b/dev-libs/protobuf/files/protobuf-3.15.0-protoc_input_output_files.patch
index 3123ae5b27b5..8e9733fc4644 100644
--- a/dev-libs/protobuf/files/protobuf-3.12.0-protoc_input_output_files.patch
+++ b/dev-libs/protobuf/files/protobuf-3.15.0-protoc_input_output_files.patch
@@ -2,7 +2,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
--- /src/google/protobuf/compiler/command_line_interface.cc
+++ /src/google/protobuf/compiler/command_line_interface.cc
-@@ -997,6 +997,28 @@
+@@ -1109,6 +1109,28 @@
}
if (mode_ == MODE_ENCODE || mode_ == MODE_DECODE) {
@@ -31,7 +31,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
if (codec_type_.empty()) {
// HACK: Define an EmptyMessage type to use for decoding.
DescriptorPool pool;
-@@ -1005,13 +1027,20 @@
+@@ -1117,13 +1139,20 @@
file.add_message_type()->set_name("EmptyMessage");
GOOGLE_CHECK(pool.BuildFile(file) != NULL);
codec_type_ = "EmptyMessage";
@@ -58,7 +58,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
}
}
-@@ -1049,6 +1078,11 @@
+@@ -1161,6 +1190,11 @@
for (int i = 0; i < proto_path_.size(); i++) {
source_tree->MapPath(proto_path_[i].first, proto_path_[i].second);
}
@@ -70,9 +70,9 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Map input files to virtual paths if possible.
if (!MakeInputsBeProtoPathRelative(source_tree, fallback_database)) {
-@@ -1750,6 +1784,12 @@
-
- codec_type_ = value;
+@@ -1892,6 +1926,12 @@
+ } else if (name == "--deterministic_output") {
+ deterministic_output_ = true;
+ } else if (name == "--protobuf_in") {
+ protobuf_in_path_ = value;
@@ -83,75 +83,53 @@ https://github.com/protocolbuffers/protobuf/pull/235
} else if (name == "--error_format") {
if (value == "gcc") {
error_format_ = ERROR_FORMAT_GCC;
-@@ -1886,29 +1926,50 @@
- " -h, --help Show this text and exit.\n"
- " --encode=MESSAGE_TYPE Read a text-format message of the "
- "given type\n"
-- " from standard input and write it in "
-- "binary\n"
-- " to standard output. The message type "
-- "must\n"
-+ " and write it in binary. The message "
-+ "type must\n"
- " be defined in PROTO_FILES or their "
- "imports.\n"
-+ " The input/output protobuf files are "
-+ "specified\n"
-+ " using the --protobuf_in and "
-+ "--protobuf_out\n"
-+ " command line flags.\n"
- " --decode=MESSAGE_TYPE Read a binary message of the given "
-- "type from\n"
-- " standard input and write it in text "
-- "format\n"
-- " to standard output. The message type "
-- "must\n"
-- " be defined in PROTO_FILES or their "
-- "imports.\n"
-+ "type and\n"
-+ " write it in text format. The message "
-+ "type\n"
-+ " must be defined in PROTO_FILES or "
-+ "their imports.\n"
-+ " The input/output protobuf files are "
-+ "specified\n"
-+ " using the --protobuf_in and "
-+ "--protobuf_out\n"
-+ " command line flags.\n"
- " --decode_raw Read an arbitrary protocol message "
-- "from\n"
-- " standard input and write the raw "
-- "tag/value\n"
-- " pairs in text format to standard "
-- "output. No\n"
-+ "and write\n"
-+ " the raw tag/value pairs in text format."
-+ " No\n"
- " PROTO_FILES should be given when using "
- "this\n"
-- " flag.\n"
-+ " flag. The input/output protobuf files "
-+ "are\n"
-+ " specified using the --protobuf_in and\n"
-+ " --protobuf_out command line flags.\n"
-+ " --protobuf_in=FILE Absolute path to the protobuf file "
-+ "from which\n"
-+ " input of encoding/decoding operation "
-+ "will be\n"
-+ " read. If omitted, input will be read "
-+ "from\n"
-+ " standard input.\n"
-+ " --protobuf_out=FILE Absolute path to the protobuf file "
-+ "to which\n"
-+ " output of encoding/decoding operation "
-+ "will be\n"
-+ " written. If omitted, output will be "
-+ "written to\n"
-+ " standard output.\n"
- " --descriptor_set_in=FILES Specifies a delimited list of FILES\n"
- " each containing a FileDescriptorSet "
- "(a\n"
-@@ -2254,7 +2315,9 @@
+@@ -2019,22 +2059,38 @@
+ --version Show version info and exit.
+ -h, --help Show this text and exit.
+ --encode=MESSAGE_TYPE Read a text-format message of the given type
+- from standard input and write it in binary
+- to standard output. The message type must
++ from input protobuf file and write it in binary
++ to output protobuf file. The message type must
+ be defined in PROTO_FILES or their imports.
++ The input/output protobuf files are specified
++ using the --protobuf_in and --protobuf_out
++ command line flags.
+ --deterministic_output When using --encode, ensure map fields are
+ deterministically ordered. Note that this order
+ is not canonical, and changes across builds or
+ releases of protoc.
+ --decode=MESSAGE_TYPE Read a binary message of the given type from
+- standard input and write it in text format
+- to standard output. The message type must
++ input protobuf file and write it in text format
++ to output protobuf file. The message type must
+ be defined in PROTO_FILES or their imports.
++ The input/output protobuf files are specified
++ using the --protobuf_in and --protobuf_out
++ command line flags.
+ --decode_raw Read an arbitrary protocol message from
+- standard input and write the raw tag/value
+- pairs in text format to standard output. No
++ input protobuf file and write the raw tag/value
++ pairs in text format to output protobuf file. No
+ PROTO_FILES should be given when using this
+- flag.
++ flag. The input/output protobuf files are
++ specified using the --protobuf_in and
++ --protobuf_out command line flags.
++ --protobuf_in=FILE Absolute path to the protobuf file from which
++ input of encoding/decoding operation will be
++ read. If omitted, input will be read from
++ standard input.
++ --protobuf_out=FILE Absolute path to the protobuf file to which
++ output of encoding/decoding operation will be
++ written. If omitted, output will be written to
++ standard output.
+ --descriptor_set_in=FILES Specifies a delimited list of FILES
+ each containing a FileDescriptorSet (a
+ protocol buffer defined in descriptor.proto).
+@@ -2341,7 +2397,9 @@
return true;
}
@@ -162,7 +140,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// Look up the type.
const Descriptor* type = pool->FindMessageTypeByName(codec_type_);
if (type == NULL) {
-@@ -2266,15 +2329,15 @@
+@@ -2353,15 +2411,15 @@
std::unique_ptr<Message> message(dynamic_factory.GetPrototype(type)->New());
if (mode_ == MODE_ENCODE) {
@@ -213,7 +191,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
std::string descriptor_set_out_name_;
--- /src/google/protobuf/compiler/command_line_interface_unittest.cc
+++ /src/google/protobuf/compiler/command_line_interface_unittest.cc
-@@ -95,7 +95,7 @@
+@@ -97,7 +97,7 @@
virtual void SetUp();
virtual void TearDown();
@@ -222,7 +200,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
// command is automatically split on spaces, and the string "$tmpdir"
// is replaced with TestTempDir().
void Run(const std::string& command);
-@@ -2625,6 +2625,17 @@
+@@ -2596,6 +2596,17 @@
std::string::npos);
}
@@ -241,7 +219,7 @@ https://github.com/protocolbuffers/protobuf/pull/235
void WriteUnittestProtoDescriptorSet() {
unittest_proto_descriptor_set_filename_ =
@@ -2719,6 +2730,19 @@
- "net/proto2/internal/no_such_file.proto: No such file or directory\n");
+ "Can only use --deterministic_output with --encode.\n");
}
+TEST_P(EncodeDecodeTest, RedirectInputOutput) {
diff --git a/dev-libs/protobuf/files/protobuf-3.12.0-system_libraries.patch b/dev-libs/protobuf/files/protobuf-3.15.0-system_libraries.patch
index cd7c3493da86..9a75a6665f0c 100644
--- a/dev-libs/protobuf/files/protobuf-3.12.0-system_libraries.patch
+++ b/dev-libs/protobuf/files/protobuf-3.15.0-system_libraries.patch
@@ -47,7 +47,7 @@
AC_OUTPUT
--- /src/Makefile.am
+++ /src/Makefile.am
-@@ -711,19 +711,11 @@
+@@ -703,19 +703,11 @@
google/protobuf/testing/file.cc \
google/protobuf/testing/file.h
@@ -68,7 +68,7 @@
# Disable optimization for tests unless the user explicitly asked for it,
# since test_util.cc takes forever to compile with optimization (with GCC).
# See configure.ac for more info.
-@@ -815,12 +807,8 @@
+@@ -807,12 +799,8 @@
# Run cpp_unittest again with PROTOBUF_TEST_NO_DESCRIPTORS defined.
protobuf_lazy_descriptor_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
libprotoc.la \
@@ -83,7 +83,7 @@
protobuf_lazy_descriptor_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lazy_descriptor_test_SOURCES = \
google/protobuf/compiler/cpp/cpp_unittest.cc \
-@@ -841,11 +829,7 @@
+@@ -833,11 +821,7 @@
# full runtime and we want to make sure this test builds without full
# runtime.
protobuf_lite_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
@@ -96,7 +96,7 @@
protobuf_lite_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_test_SOURCES = \
google/protobuf/lite_unittest.cc \
-@@ -857,11 +841,7 @@
+@@ -849,11 +833,7 @@
# gtest when building the test internally our memory sanitizer doesn't detect
# memory leaks (don't know why).
protobuf_lite_arena_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
@@ -109,7 +109,7 @@
protobuf_lite_arena_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_arena_test_SOURCES = \
google/protobuf/lite_arena_unittest.cc \
-@@ -871,8 +851,7 @@
+@@ -863,8 +843,7 @@
# Test plugin binary.
test_plugin_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \