summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf/protobuf-3.17.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-libs/protobuf/protobuf-3.17.2.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-libs/protobuf/protobuf-3.17.2.ebuild')
-rw-r--r--dev-libs/protobuf/protobuf-3.17.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-libs/protobuf/protobuf-3.17.2.ebuild b/dev-libs/protobuf/protobuf-3.17.2.ebuild
index 390df7df0b7c..ab50d514273e 100644
--- a/dev-libs/protobuf/protobuf-3.17.2.ebuild
+++ b/dev-libs/protobuf/protobuf-3.17.2.ebuild
@@ -58,6 +58,9 @@ src_prepare() {
# https://github.com/protocolbuffers/protobuf/issues/8460
sed -e "/^TEST(AnyTest, TestPackFromSerializationExceedsSizeLimit) {$/a\\ if (sizeof(void*) == 4) {\n GTEST_SKIP();\n }" -i src/google/protobuf/any_test.cc || die
+ # https://github.com/protocolbuffers/protobuf/issues/9392
+ sed -e "s/^AC_PROG_OBJC$/AS_CASE([\$target_os], [darwin*], [AC_PROG_OBJC], [AM_CONDITIONAL([am__fastdepOBJC], [false])])/" -i configure.ac || die
+
eautoreconf
}
@@ -74,7 +77,6 @@ src_configure() {
multilib_src_configure() {
local options=(
- OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)