summaryrefslogtreecommitdiff
path: root/dev-libs/qcustomplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/qcustomplot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/qcustomplot')
-rw-r--r--dev-libs/qcustomplot/Manifest4
-rw-r--r--dev-libs/qcustomplot/metadata.xml8
-rw-r--r--dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/Manifest b/dev-libs/qcustomplot/Manifest
new file mode 100644
index 000000000000..775d5fec2ed1
--- /dev/null
+++ b/dev-libs/qcustomplot/Manifest
@@ -0,0 +1,4 @@
+DIST qcustomplot-sharedlib-2.0.0.tar.gz 1949 BLAKE2B 6d2d1b7da0dbdb83485ce1a1b69b5d4270fa73af25240decd1764d0872065a7457252aac3b81ccc9d5cbcfe24f8ed67ff843f092b344065b8b0f26aa2c6bef14 SHA512 f4ba719287067c2bb999a6e4ffb3694b32b1d72867c396fee1834ba2916f2931eda07bbe25c4d2ea6f6af18bd78917660dc6eabd98f72c9da987ae288ed4e611
+DIST qcustomplot-source-2.0.0.tar.gz 317398 BLAKE2B c2d587e06026789a164f16ffdd00d324172654b6953ace637815b022dc14cc96362cf4022512ec3feea3725a651c1af0f50f09d0ca1c5e86ebcfbe3f50aa3ff2 SHA512 66c648877ed0a14cf527ac8526788065f494119cc61993d20268a0046c8e6c5a1c73a61f50a73e6a39ec55435bc5f74c613ee21254293ddab34ba7c2484c4f5a
+EBUILD qcustomplot-2.0.0.ebuild 973 BLAKE2B 28c0e3346503b06093911f40f2a55e87a911f926fe565538797be17834f999eef646b02c9612ebf207d83b0744becc80b7cc33685578306d043c57a2cae18a42 SHA512 8cc536cc761ebc88c5d820f075f2977eec99aa37c638838ab77915b0d0c6239f575da513cfb556765629310ab3a3df662b5fd10ecf7a4ae2f5452cd0e69a1997
+MISC metadata.xml 247 BLAKE2B 1428e575bd9b69424c4711499480493ae371840c146149819dc41c38335cbd16d7ce50ce8f6b7be1b77db73092ed6900a9a2d8032cc790058a56e533b01f562d SHA512 b43c8e84c3c753b49b203921a5aca792639a36d6efdbe16c069ff9abfbce0585718bb3824c03abdd7bd19ada13fb0a98a378c85ed369ac5fdc53ad3b3d5465d2
diff --git a/dev-libs/qcustomplot/metadata.xml b/dev-libs/qcustomplot/metadata.xml
new file mode 100644
index 000000000000..17237689dcfd
--- /dev/null
+++ b/dev-libs/qcustomplot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild b/dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild
new file mode 100644
index 000000000000..c5e360b617d4
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="http://www.qcustomplot.com/"
+SRC_URI="
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-source
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}