summaryrefslogtreecommitdiff
path: root/dev-libs/qrosspython/qrosspython-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/qrosspython/qrosspython-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/qrosspython/qrosspython-9999.ebuild')
-rw-r--r--dev-libs/qrosspython/qrosspython-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/qrosspython/qrosspython-9999.ebuild b/dev-libs/qrosspython/qrosspython-9999.ebuild
new file mode 100644
index 000000000000..c7d265051246
--- /dev/null
+++ b/dev-libs/qrosspython/qrosspython-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit git-r3 python-single-r1 cmake-utils
+
+EGIT_REPO_URI="https://github.com/0xd34df00d/Qross.git"
+
+DESCRIPTION="Python scripting backend for Qross"
+HOMEPAGE="https://github.com/0xd34df00d/Qross"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND="
+ ~dev-libs/qrosscore-${PV}
+ dev-python/sip
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CMAKE_USE_DIR="${S}/src/bindings/python/qrosspython"
+
+mycmakeargs=( -DUSE_QT5=ON )