summaryrefslogtreecommitdiff
path: root/dev-libs/rapidxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-libs/rapidxml
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-libs/rapidxml')
-rw-r--r--dev-libs/rapidxml/Manifest3
-rw-r--r--dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch48
-rw-r--r--dev-libs/rapidxml/rapidxml-1.13-r1.ebuild1
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/rapidxml/Manifest b/dev-libs/rapidxml/Manifest
index b71fbc1fa0b3..131373d6db36 100644
--- a/dev-libs/rapidxml/Manifest
+++ b/dev-libs/rapidxml/Manifest
@@ -1,4 +1,5 @@
AUX rapidxml-1.13-clang.patch 1650 BLAKE2B 6e807a3266dbaa5a575a7036ec65b2ce6cfdb3347f4baa0c776f7ba2791fb363fb861994363a9131111e61a40f0aef818ad2e484b0b9f8d676a1cebc79be7d85 SHA512 b55735e503fbf51fa24c381effb1346dde3a2d31f0a4320634fab816832d75b23f51839f280d837247bc228d59504170bda1c1350898f9b4f79c011084f0d0e3
+AUX rapidxml-1.13-iterators.patch 1627 BLAKE2B aa5404188f12d0c193ececb43bcf0491ae03579535485f8d677b9621255b876165261007c775223851816a8552f0268349f11f54dc50fae3efbb2c0bd365a4a8 SHA512 37c5555ccc1a39f503d84e9209180937a63e431d8e5009d54e99335b2f0808b0e6c2bd6e551dca72ab535e4ac805660082de3f244b0605efd9884a9adb2bf57a
DIST rapidxml-1.13.zip 44163 BLAKE2B 9db90dfca1943c47e95541a323e1210368447c054cf072d6768031488070e375fe2aa78a4e41f61f252d4c487e94cf1e24e4d3756e3f8774b0c2c52ef86959e7 SHA512 6c10583e6631ccdb0217d0a5381172cb4c1046226de6ef1acf398d85e81d145228e14c3016aefcd7b70a1db8631505b048d8b4f5d4b0dbf1811d2482eefdd265
-EBUILD rapidxml-1.13-r1.ebuild 470 BLAKE2B 5980f833c7b4731a142bc1247927352a21a62e304016df596bb32b5ec5746bcaae00ad849461209a2adb2c23beb025d864241978e90a21327a84b99be7b6dcd0 SHA512 ff849cc207629d4ea144c81d0c98b5e17d924a2fd64d249eceb9c18c2a866bd668569874845b10f5da14a9c38acde42ba94dfd69d1c7e2039a0ff0a1b8a4fdf9
+EBUILD rapidxml-1.13-r1.ebuild 506 BLAKE2B b1cfe9b7a953971e2b2170c9021bd9a838830460cf2f069fac2b03cce3fa9f842f1fc32f657473cadb4d808c6f1a2b4cb4ae87820b81354637723ec9fc6078c3 SHA512 8e18151c110bd6478a291332912d82d9eb0744e31268fb0e4a9ff287d233b98c3c31af498f7a43b954af0d1a1968cd337a732bc1a0b7a7771bc2fc8bc6e08793
MISC metadata.xml 331 BLAKE2B 76a526f6ca4463cd836f236c88d20308be9ce4660a996c8efec1cb4266c776692e8cdebdea353d9c91f8b86cfdf9e697a2ca8c5ad60b3a790c7c19fd62e41578 SHA512 b38279f1436fa145a86830d5aada7ac41581c16aadab546621a0cabf72c1ca26b275c158a1a051e4b47f16e936c5c93bb7d5f8e386dfa9b5135b434d3034af22
diff --git a/dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch b/dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch
new file mode 100644
index 000000000000..068545241388
--- /dev/null
+++ b/dev-libs/rapidxml/files/rapidxml-1.13-iterators.patch
@@ -0,0 +1,48 @@
+https://sources.debian.org/data/main/r/rapidxml/1.13-3/debian/patches/fix-iterators.patch
+https://bugs.gentoo.org/791328
+--- a/rapidxml_iterators.hpp
++++ b/rapidxml_iterators.hpp
+@@ -18,9 +18,9 @@
+
+ public:
+
+- typedef typename xml_node<Ch> value_type;
+- typedef typename xml_node<Ch> &reference;
+- typedef typename xml_node<Ch> *pointer;
++ typedef typename rapidxml::xml_node<Ch> value_type;
++ typedef typename rapidxml::xml_node<Ch> &reference;
++ typedef typename rapidxml::xml_node<Ch> *pointer;
+ typedef std::ptrdiff_t difference_type;
+ typedef std::bidirectional_iterator_tag iterator_category;
+
+@@ -56,7 +56,7 @@
+ node_iterator operator++(int)
+ {
+ node_iterator tmp = *this;
+- ++this;
++ ++(*this);
+ return tmp;
+ }
+
+@@ -70,7 +70,7 @@
+ node_iterator operator--(int)
+ {
+ node_iterator tmp = *this;
+- ++this;
++ ++(*this);
+ return tmp;
+ }
+
+@@ -97,9 +97,9 @@
+
+ public:
+
+- typedef typename xml_attribute<Ch> value_type;
+- typedef typename xml_attribute<Ch> &reference;
+- typedef typename xml_attribute<Ch> *pointer;
++ typedef typename rapidxml::xml_attribute<Ch> value_type;
++ typedef typename rapidxml::xml_attribute<Ch> &reference;
++ typedef typename rapidxml::xml_attribute<Ch> *pointer;
+ typedef std::ptrdiff_t difference_type;
+ typedef std::bidirectional_iterator_tag iterator_category;
+
diff --git a/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild b/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
index 80a5284c808b..d072ba673bc9 100644
--- a/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
+++ b/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~x86"
BDEPEND="app-arch/unzip"
PATCHES=(
+ "${FILESDIR}"/${P}-iterators.patch
"${FILESDIR}"/${P}-clang.patch
)