summaryrefslogtreecommitdiff
path: root/dev-libs/roct-thunk-interface/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /dev-libs/roct-thunk-interface/files
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'dev-libs/roct-thunk-interface/files')
-rw-r--r--dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-libpath.patch13
-rw-r--r--dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-linklibLLVM.patch31
-rw-r--r--dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-skipIPCtest.patch20
-rw-r--r--dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.0.0-functions.patch12
-rw-r--r--dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.1.0-visibility.patch26
5 files changed, 90 insertions, 12 deletions
diff --git a/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-libpath.patch b/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-libpath.patch
new file mode 100644
index 000000000000..1d7d73ad7a8a
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-libpath.patch
@@ -0,0 +1,13 @@
+The built hsakmt library is right under BUILD_DIR, not BUILD_DIR/lib
+===================================================================
+--- a/tests/kfdtest/CMakeLists.txt
++++ b./tests/kfdtest/CMakeLists.txt
+@@ -117,7 +117,7 @@ else()
+ endif()
+
+ if( DEFINED LIBHSAKMT_PATH )
+- set ( HSAKMT_LIBRARY_DIRS ${LIBHSAKMT_PATH}/lib )
++ set ( HSAKMT_LIBRARY_DIRS ${LIBHSAKMT_PATH}/ )
+ set ( HSAKMT_LIBRARIES hsakmt )
+ endif()
+
diff --git a/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-linklibLLVM.patch b/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-linklibLLVM.patch
new file mode 100644
index 000000000000..61d8b99bf335
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-linklibLLVM.patch
@@ -0,0 +1,31 @@
+https://github.com/ROCm/ROCT-Thunk-Interface/pull/102
+From 6d7d48bb6843405aac2777388edf4c7c2a6f9dc3 Mon Sep 17 00:00:00 2001
+From: Yiyang Wu <xgreenlandforwyy@gmail.com>
+Date: Tue, 30 Apr 2024 13:35:08 +0800
+Subject: [PATCH] Allow linking libLLVM dynamic library rather than separate
+ components
+
+---
+ tests/kfdtest/CMakeLists.txt | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/kfdtest/CMakeLists.txt b/tests/kfdtest/CMakeLists.txt
+index 9d1172e..ccad7f4 100644
+--- a/tests/kfdtest/CMakeLists.txt
++++ b/tests/kfdtest/CMakeLists.txt
+@@ -154,7 +154,11 @@ include_directories(${LLVM_INCLUDE_DIRS})
+ separate_arguments(LLVM_DEFINITIONS_LIST NATIVE_COMMAND ${LLVM_DEFINITIONS})
+ add_definitions(${LLVM_DEFINITIONS_LIST})
+
+-llvm_map_components_to_libnames(llvm_libs AMDGPUAsmParser Core Support)
++if (LLVM_LINK_LLVM_DYLIB)
++ set(llvm_libs LLVM)
++else()
++ llvm_map_components_to_libnames(llvm_libs AMDGPUAsmParser Core Support)
++endif()
+
+ include_directories(${PROJECT_SOURCE_DIR}/gtest-1.6.0)
+ include_directories(${PROJECT_SOURCE_DIR}/include)
+--
+2.44.0
+
diff --git a/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-skipIPCtest.patch b/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-skipIPCtest.patch
new file mode 100644
index 000000000000..cca728dad601
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/files/kfdtest-6.1.0-skipIPCtest.patch
@@ -0,0 +1,20 @@
+Issue: https://github.com/ROCm/ROCT-Thunk-Interface/issues/103
+===================================================================
+--- ROCT-Thunk-Interface-rocm-6.1.1.orig/tests/kfdtest/scripts/kfdtest.exclude
++++ ROCT-Thunk-Interface-rocm-6.1.1/tests/kfdtest/scripts/kfdtest.exclude
+@@ -63,6 +63,7 @@ PERMANENT_BLACKLIST_ALL_ASICS=\
+ # failures can be found
+ # NOTE: If you update this alphabetical listing, add the corresponding JIRA ticket for reference
+ #
++# KFDIPCTest.BasicTest are not compatible with upstream amdgpu kernel module
+ # KFDQMTest.GPUDoorbellWrite fails intermittently (KFD-318)
+ # KFDQMTest.mGPUShareBO (KFD-334)
+ # KFDHWSTest.* (SWDEV-193035)
+@@ -72,6 +73,7 @@ PERMANENT_BLACKLIST_ALL_ASICS=\
+ # KFDDBGTest.SuspendQueues (SWDEV-417850)
+ # KFDDBGTest.HitAddressWatch (SWDEV-420281)
+ TEMPORARY_BLACKLIST_ALL_ASICS=\
++"KFDIPCTest.BasicTest:"\
+ "KFDQMTest.GPUDoorbellWrite:"\
+ "KFDQMTest.mGPUShareBO:"\
+ "KFDQMTest.SdmaEventInterrupt:"\
diff --git a/dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.0.0-functions.patch b/dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.0.0-functions.patch
deleted file mode 100644
index cbea737c4b4c..000000000000
--- a/dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.0.0-functions.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/libhsakmt.ver b/src/libhsakmt.ver
-index 15c2916..c04cefe 100644
---- a/src/libhsakmt.ver
-+++ b/src/libhsakmt.ver
-@@ -81,6 +81,7 @@ hsaKmtWaitOnEvent_Ext;
- hsaKmtWaitOnMultipleEvents_Ext;
- hsaKmtReplaceAsanHeaderPage;
- hsaKmtReturnAsanHeaderPage;
-+hsaKmtGetAMDGPUDeviceHandle;
-
- local: *;
- };
diff --git a/dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.1.0-visibility.patch b/dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.1.0-visibility.patch
new file mode 100644
index 000000000000..d907d2f13e41
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/files/roct-thunk-interface-6.1.0-visibility.patch
@@ -0,0 +1,26 @@
+https://github.com/ROCm/ROCT-Thunk-Interface/pull/102
+From 8385d8795b994f31e00e651dc4f41e18d82ff968 Mon Sep 17 00:00:00 2001
+From: Yiyang Wu <xgreenlandforwyy@gmail.com>
+Date: Tue, 30 Apr 2024 15:07:12 +0800
+Subject: [PATCH] hsaKmtCheckRuntimeDebugSupport should be visible for kfdtest
+
+---
+ src/debug.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/debug.c b/src/debug.c
+index 932e829..67c32c8 100644
+--- a/src/debug.c
++++ b/src/debug.c
+@@ -268,7 +268,7 @@ HSAKMT_STATUS HSAKMTAPI hsaKmtDbgAddressWatch(HSAuint32 NodeId,
+ #define HSA_RUNTIME_ENABLE_MAX_MAJOR 1
+ #define HSA_RUNTIME_ENABLE_MIN_MINOR 13
+
+-HSAKMT_STATUS hsaKmtCheckRuntimeDebugSupport(void) {
++HSAKMT_STATUS HSAKMTAPI hsaKmtCheckRuntimeDebugSupport(void) {
+ HsaNodeProperties node = {0};
+ HsaSystemProperties props = {0};
+ HsaVersionInfo versionInfo = {0};
+--
+2.44.0
+