summaryrefslogtreecommitdiff
path: root/dev-libs/sexp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /dev-libs/sexp
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'dev-libs/sexp')
-rw-r--r--dev-libs/sexp/Manifest4
-rw-r--r--dev-libs/sexp/files/sexp-0.8.3-fix-missing-cstdint-include.patch11
-rw-r--r--dev-libs/sexp/metadata.xml14
-rw-r--r--dev-libs/sexp/sexp-0.8.3.ebuild42
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/sexp/Manifest b/dev-libs/sexp/Manifest
new file mode 100644
index 000000000000..b79b25e14ff9
--- /dev/null
+++ b/dev-libs/sexp/Manifest
@@ -0,0 +1,4 @@
+AUX sexp-0.8.3-fix-missing-cstdint-include.patch 321 BLAKE2B d8a81293c6a958efd8f8e7af0bc5f89d08939ba6c5717cac63b59ff7301341b1bcee894be6797064375a28e9fda92594ab21096da55c33b53382fd5e0d713dd2 SHA512 64e5ce13917598806c69255e39088f5cdf9b64c824458e80bf872ef0f24aff09ac6379329da0f2f3b4ce055405167fe9828571ee55d7ec2e41ab653c48b2731f
+DIST sexp-0.8.3.tar.gz 45973 BLAKE2B 9d07c52aa5dc26b8b2f20d3e0ea2ab3bdda3e8fdfe1eca4aea14e49a8acb09f59315ef9b19376ec6c75e552307dcfc62e6a8f4ade37b333b9f7f221d1e835d2c SHA512 ad3ca70aa779f26f70b280258e13357b3ac38e9d9a409a42db6bf8ace82957c432ba3163c5026360c476abb3d8ffb150a86bc5cdaa7a9c3eb1f9a1af47a4d4a6
+EBUILD sexp-0.8.3.ebuild 864 BLAKE2B 213c0d148a6a149c0134b7fa82fdd0037a07376090af874fc73898626e0417ef4efec64077891a8038c1f6430e2099f759cee0f58089ef7a2fca57c6414f18e5 SHA512 0bbc94f7a6e6641db8f415f1c9440763e1e400645a1b286dd58ec5634cef593d7b05d985f21f4c6bddc2aa6cc05a24c2e8e2a10a02bc9cccf52d90df310e047d
+MISC metadata.xml 416 BLAKE2B 27e50ec619e18e7be4a3bf8cb0e77b3ffd125383022daba849ec49b4d30afedc2e3dfec37f665a3728b30435add3c29170539ba0362f399dbae7dd2bbafa5f74 SHA512 87ab71623c30ee40662a076e59e18afcc3d6a59eff5960111f866c944eaba27ace2e553cb072bb63fa8b9857f348079723d087335236831a1bfbf11841168640
diff --git a/dev-libs/sexp/files/sexp-0.8.3-fix-missing-cstdint-include.patch b/dev-libs/sexp/files/sexp-0.8.3-fix-missing-cstdint-include.patch
new file mode 100644
index 000000000000..289437523b22
--- /dev/null
+++ b/dev-libs/sexp/files/sexp-0.8.3-fix-missing-cstdint-include.patch
@@ -0,0 +1,11 @@
+diff -Naur a/include/sexp/sexp-error.h b/include/sexp/sexp-error.h
+--- a/include/sexp/sexp-error.h 2023-04-19 15:01:09.000000000 +0300
++++ b/include/sexp/sexp-error.h 2023-05-03 10:25:42.872644722 +0300
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <exception>
+ #include <iostream>
+ #include <string>
diff --git a/dev-libs/sexp/metadata.xml b/dev-libs/sexp/metadata.xml
new file mode 100644
index 000000000000..63224ff33ddb
--- /dev/null
+++ b/dev-libs/sexp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>mozilla@gentoo.org</email>
+ <name>Gentoo Mozilla Team</name>
+ </maintainer>
+ <use>
+ <flag name="cli">Build sexp console application</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rnpgp/sexp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/sexp/sexp-0.8.3.ebuild b/dev-libs/sexp/sexp-0.8.3.ebuild
new file mode 100644
index 000000000000..d4185eaf642f
--- /dev/null
+++ b/dev-libs/sexp/sexp-0.8.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="S-expressions parser and generator library in C++"
+HOMEPAGE="https://github.com/rnpgp/sexp"
+SRC_URI="https://github.com/rnpgp/sexp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cli static-libs test"
+
+BDEPEND="virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/sexp-0.8.3-fix-missing-cstdint-include.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOWNLOAD_GTEST=off
+
+ -DWITH_COVERAGE=off
+ -DWITH_SANITIZERS=off
+ -DWITH_SEXP_CLI=$(usex cli on off)
+ -DWITH_SEXP_TESTS=$(usex test on off)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if ! use static-libs; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+}