summaryrefslogtreecommitdiff
path: root/dev-libs/shhopt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-libs/shhopt/files
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-libs/shhopt/files')
-rw-r--r--dev-libs/shhopt/files/shhopt-1.1.7-build.patch60
1 files changed, 23 insertions, 37 deletions
diff --git a/dev-libs/shhopt/files/shhopt-1.1.7-build.patch b/dev-libs/shhopt/files/shhopt-1.1.7-build.patch
index 3405511e2238..954011994bc9 100644
--- a/dev-libs/shhopt/files/shhopt-1.1.7-build.patch
+++ b/dev-libs/shhopt/files/shhopt-1.1.7-build.patch
@@ -1,12 +1,12 @@
--- a/Makefile
+++ b/Makefile
-@@ -5,20 +5,15 @@
+@@ -5,17 +5,11 @@
VERPAT = 7
VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
-# Define SHARED as 1 for Linux shared ELF library
-#SHARED = 1
--
+
-ifeq ($(SHARED),1)
LIBTARGET = lib$(DIST).so.$(VERSION)
LIBTARGETSO = lib$(DIST).so
@@ -15,69 +15,55 @@
-else
-LIBTARGET = lib$(DIST).a
-endif
-+
-+LIBTARGETA = lib$(DIST).a
LIBHEAD = $(DIST).h
--TARGETS = $(LIBTARGET)
-+TARGETS = $(LIBTARGET) $(LIBTARGETA)
-
- INSTBASEDIR = /usr/local
- INSTLIBDIR = $(INSTBASEDIR)/lib
-@@ -27,12 +22,12 @@
+ TARGETS = $(LIBTARGET)
+@@ -27,12 +21,9 @@
INSTALLPROG = install -m 755
MKDIRP = install -d -m 755
-CC = gcc
-OPTIM = -O2
-
--INCDIR = -I.
--
+ INCDIR = -I.
+
-CCOPT = -s -Wall $(OPTIM) $(INCDIR)
-+CC ?= gcc
-+AR ?= ar
-+ARFLAGS ?= rc
-+RANLIB ?= ranlib
-+CPPFLAGS += -I.
-+CFLAGS += -Wall
++CCOPT = -Wall $(INCDIR)
# Object files to store in the library
LIBOBJS = shhopt.o
-@@ -43,21 +38,19 @@
- # don't worry if you get ranlib not found errors. This probably means
+@@ -44,12 +35,7 @@
# that your ar does an implicit ranlib and you do not need to run ranlib
# separately. This error is harmless.
--$(LIBTARGET): $(LIBOBJS)
+ $(LIBTARGET): $(LIBOBJS)
-ifeq ($(SHARED),1)
- $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
-else
- ar rc $(LIBTARGET) $(LIBOBJS)
- ranlib $(LIBTARGET) || true
-endif
-+$(LIBTARGET): $(LIBOBJS:.o=.lo)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $@ $^
-+$(LIBTARGETA): $(LIBOBJS)
-+ $(AR) $(ARFLAGS) $@ $^
-+ $(RANLIB) $@
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
# Note that you may need GNU's -liberty if your libc lacks strtoul
example: $(LIBTARGET) example.o
- $(CC) -o example example.c \
+@@ -57,7 +43,7 @@
-L. -I. -L$(INSTLIBDIR) -I$(INSTINCDIR) -lshhopt
--.c.o:
+ .c.o:
- $(CC) $(CCSHRD) -o $@ -c $(CCOPT) $<
-+%.lo: %.c
-+ $(COMPILE.c) $(CCSHRD) $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(CCSHRD) -o $@ -c $(CCOPT) $<
depend dep:
$(CC) $(INCDIR) -MM *.c >depend
-@@ -73,7 +66,7 @@
- endif
+@@ -66,11 +52,9 @@
+ $(MKDIRP) $(INSTLIBDIR) $(INSTINCDIR)
+ $(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
+ $(INSTALL) $(LIBHEAD) $(INSTINCDIR)
+-ifeq ($(SHARED),1)
+ ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
+ ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
+ echo "Now run ldconfig if necessary."
+-endif
clean:
-- rm -f *.o core *~ depend
-+ rm -f *.o *.lo *.so* *.a core *~ depend
-
- chmod:
- chmod a+r *
+ rm -f *.o core *~ depend