summaryrefslogtreecommitdiff
path: root/dev-libs/stp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-libs/stp
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-libs/stp')
-rw-r--r--dev-libs/stp/Manifest3
-rw-r--r--dev-libs/stp/metadata.xml26
-rw-r--r--dev-libs/stp/stp-2.3.3.ebuild44
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/stp/Manifest b/dev-libs/stp/Manifest
new file mode 100644
index 000000000000..7b40427ab190
--- /dev/null
+++ b/dev-libs/stp/Manifest
@@ -0,0 +1,3 @@
+DIST stp-2.3.3.tar.gz 2577550 BLAKE2B 9ebedf3cb8e6b50d037cfacbc14826bd4e6505d29a53b1fcc6580749f0637fe5f96619c166babdb3a52b18fb6337e49c02f5693e233effe84d0131d0e7402381 SHA512 a0b1bf419d8230e40ce0aee90d9c8c9d814aca300831c24b3576c75623362942abf20673c419f9f0ea1e0505bfae000dc65fdd818179f5759879b0b255f1b99a
+EBUILD stp-2.3.3.ebuild 975 BLAKE2B 0cef0581142eaccdc0df77e7ece8dc0528e8390583b86e70dd263495a12f9234fd1806d721bca8168531d2902610b2ae5bd9f52ed02207266a9fc017becdb55e SHA512 a96b98f8afb1293fba8865b509cb0f04595ebc435e699d55075df3756843c0316629021347c73d954f579dc6ca487e620eb1964953a3d8820b292706c52df259
+MISC metadata.xml 881 BLAKE2B bb604f1cf823b06a4d7bff96ec805bc2418dfcdeeaa17ca88f98c509b687b7467f7c6864d25294d8f1f1e4cbaf0e7d99b82edd27fcdc552353fe5510d1fbe375 SHA512 4b3e243ae419cb974f49b6d37e3e807f5ff0676cd989dc145fcd716c23bd2292177935658ea899afd9fc37a18dffc8c0949dee4a25b2e493db0f3713703ad2cb
diff --git a/dev-libs/stp/metadata.xml b/dev-libs/stp/metadata.xml
new file mode 100644
index 000000000000..2b1417586ce7
--- /dev/null
+++ b/dev-libs/stp/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jeffrey@icurse.nl</email>
+ <name>Jeffrey Lin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ STP is a constraint solver (or SMT solver) aimed at solving
+ constraints of bitvectors and arrays. These types of
+ constraints can be generated by program analysis tools, theorem
+ provers, automated bug finders, cryptographic attack tools,
+ intelligent fuzzers, model checkers, and by many other
+ applications.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">stp/stp</remote-id>
+ </upstream>
+ <use>
+ <flag name="python">Enable building the Python interface</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-libs/stp/stp-2.3.3.ebuild b/dev-libs/stp/stp-2.3.3.ebuild
new file mode 100644
index 000000000000..df1fb807e5e4
--- /dev/null
+++ b/dev-libs/stp/stp-2.3.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
+HOMEPAGE="https://stp.github.io/"
+SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static test"
+
+DEPEND="
+ sci-mathematics/minisat
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # replace static lib with $(get_libdir)
+ sed -i "s/set(LIBDIR lib/set(LIBDIR $(get_libdir)/" CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ASSERTIONS="$(usex test)"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PYTHON_INTERFACE="$(usex python)"
+ -DSTATICCOMPILE="$(usex static)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # don't install to /usr/man
+ doman "${D}/usr/man/man1/stp.1"
+ rm -r "${D}/usr/man" || die
+}