summaryrefslogtreecommitdiff
path: root/dev-libs/template-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-libs/template-glib
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-libs/template-glib')
-rw-r--r--dev-libs/template-glib/Manifest3
-rw-r--r--dev-libs/template-glib/metadata.xml13
-rw-r--r--dev-libs/template-glib/template-glib-3.28.0.ebuild46
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/template-glib/Manifest b/dev-libs/template-glib/Manifest
new file mode 100644
index 000000000000..634dcfd65f3f
--- /dev/null
+++ b/dev-libs/template-glib/Manifest
@@ -0,0 +1,3 @@
+DIST template-glib-3.28.0.tar.xz 54320 BLAKE2B 3f06857756cc49655b0289a4c0e576c681948e347112de713e0ea3c8c47db8a68efb258688afa8277362d2fb1e5a73d2f659570607d90abf6a804ea13a9467e2 SHA512 95d780c03567a8cc1bc02ffabfed2ef4bbe359941b326bad006aba6689686421bc25d357b574cf8ab9d9a27b7707f2f6041a9fcc90a7fcedbf02e9a0e8286860
+EBUILD template-glib-3.28.0.ebuild 1057 BLAKE2B 30b223b120eacc943e47faf52022855a7ce4832263f3bb77c6f9265c1e99975f62e156d0ad5846d7a33e0f7919b3ec83b6533dec9141053b0febdd6f6ef79433 SHA512 f84b335769acf5e591fab9ed2ae8395428d8f3ccc1caf5cb9317153ac62c98746e70e067113c2cf2a4771de809fc26eb438742d256f0b9c6a5850b580fdc34b9
+MISC metadata.xml 644 BLAKE2B 76c8a25f64948739ac646ea100b365426db6b9f674502d2db83a93ad7203bcf2c6a49396daf959b4f3b3b89777e5f2a02c8a5a168041f6f93168f95c46fd7987 SHA512 272335daa1c3844c85dde4fe91b5020112c0652547d644fdb04126219ea39a3c0cfc16bb3d054cc362393507844e9a63d4c24e5e0f323d2bb3fc8b43e65810a6
diff --git a/dev-libs/template-glib/metadata.xml b/dev-libs/template-glib/metadata.xml
new file mode 100644
index 000000000000..b776041d6e26
--- /dev/null
+++ b/dev-libs/template-glib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription>Template-GLib is a templating library for GLib. It includes a simple template
+ format along with integration into GObject-Introspection for properties and
+ methods. It separates the parsing of templates and the expansion of templates
+ for faster expansion. You can also define scope, custom functions, and more
+ with the embedded expression language.</longdescription>
+</pkgmetadata>
diff --git a/dev-libs/template-glib/template-glib-3.28.0.ebuild b/dev-libs/template-glib/template-glib-3.28.0.ebuild
new file mode 100644
index 000000000000..319031f57b3e
--- /dev/null
+++ b/dev-libs/template-glib/template-glib-3.28.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson xdg vala
+
+DESCRIPTION="Templating library for GLib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/template-glib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+IUSE="gtk-doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection:=
+" # 3.28.0 depends on go-i unconditionally, USE flag controls GIR/typelib generation
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-util/glib-utils
+ sys-devel/bison
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_tracing=false # extra trace debugging that would make things slower
+ -Denable_profiling=false # -pg passing
+ $(meson_use introspection with_introspection)
+ $(meson_use vala with_vapi)
+ $(meson_use gtk-doc enable_gtk_doc)
+ )
+ meson_src_configure
+}