summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/tinyxml2/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/tinyxml2/files')
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch20
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-4.0.1-optional-tests.patch30
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-4.0.1-xmltest.patch11
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch b/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch
new file mode 100644
index 000000000000..a6842eecb6e5
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch
@@ -0,0 +1,20 @@
+--- tinyxml2-1.0.9_p20121123/CMakeLists.txt
++++ tinyxml2-1.0.9_p20121123/CMakeLists.txt
+@@ -55,10 +55,13 @@
+ VERSION "${GENERIC_LIB_VERSION}"
+ SOVERSION "${GENERIC_LIB_SOVERSION}")
+
+-add_executable(test xmltest.cpp)
+-add_dependencies(test tinyxml2)
+-add_dependencies(test ${TARGET_DATA_COPY})
+-target_link_libraries(test tinyxml2)
++set(BUILD_TEST OFF CACHE BOOL "Set to ON to build tests")
++if(BUILD_TEST)
++ add_executable(test xmltest.cpp)
++ add_dependencies(test tinyxml2)
++ add_dependencies(test ${TARGET_DATA_COPY})
++ target_link_libraries(test tinyxml2)
++endif(BUILD_TEST)
+
+
+ if(BUILD_STATIC_LIBS)
diff --git a/dev-libs/tinyxml2/files/tinyxml2-4.0.1-optional-tests.patch b/dev-libs/tinyxml2/files/tinyxml2-4.0.1-optional-tests.patch
new file mode 100644
index 000000000000..95e849fdc8ff
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-4.0.1-optional-tests.patch
@@ -0,0 +1,30 @@
+--- tinyxml2-4.0.1/CMakeLists.txt
++++ tinyxml2-4.0.1/CMakeLists.txt
+@@ -100,15 +100,18 @@
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+
+-add_executable(xmltest xmltest.cpp)
+-if(BUILD_SHARED_LIBS)
+- add_dependencies(xmltest tinyxml2)
+- add_dependencies(xmltest ${TARGET_DATA_COPY})
+- target_link_libraries(xmltest tinyxml2)
+-else(BUILD_STATIC_LIBS)
+- add_dependencies(xmltest tinyxml2_static)
+- add_dependencies(xmltest ${TARGET_DATA_COPY})
+- target_link_libraries(xmltest tinyxml2_static)
++set(BUILD_TEST OFF CACHE BOOL "Set to ON to build tests")
++if(BUILD_TEST)
++ add_executable(xmltest xmltest.cpp)
++ if(BUILD_SHARED_LIBS)
++ add_dependencies(xmltest tinyxml2)
++ add_dependencies(xmltest ${TARGET_DATA_COPY})
++ target_link_libraries(xmltest tinyxml2)
++ else(BUILD_STATIC_LIBS)
++ add_dependencies(xmltest tinyxml2_static)
++ add_dependencies(xmltest ${TARGET_DATA_COPY})
++ target_link_libraries(xmltest tinyxml2_static)
++ endif()
+ endif()
+ install(TARGETS DESTINATION ${CMAKE_INSTALL_BINDIR})
+
diff --git a/dev-libs/tinyxml2/files/tinyxml2-4.0.1-xmltest.patch b/dev-libs/tinyxml2/files/tinyxml2-4.0.1-xmltest.patch
new file mode 100644
index 000000000000..94b2668a1a48
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-4.0.1-xmltest.patch
@@ -0,0 +1,11 @@
+--- tinyxml2-4.0.1/xmltest.cpp
++++ tinyxml2-4.0.1/xmltest.cpp
+@@ -1618,7 +1618,7 @@
+
+ FILE* perfFP = fopen("resources/dream.xml", "r");
+ fseek(perfFP, 0, SEEK_END);
+- long size = ftell(fp);
++ long size = ftell(perfFP);
+ fseek(perfFP, 0, SEEK_SET);
+
+ char* mem = new char[size + 1];