summaryrefslogtreecommitdiff
path: root/dev-libs/tomsfastmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-libs/tomsfastmath
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-libs/tomsfastmath')
-rw-r--r--dev-libs/tomsfastmath/Manifest2
-rw-r--r--dev-libs/tomsfastmath/files/tomsfastmath-0.13.1-export-fp_isprime_ex.patch13
-rw-r--r--dev-libs/tomsfastmath/tomsfastmath-0.13.1-r1.ebuild69
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/tomsfastmath/Manifest b/dev-libs/tomsfastmath/Manifest
index 7ffb487eea57..2ec459570522 100644
--- a/dev-libs/tomsfastmath/Manifest
+++ b/dev-libs/tomsfastmath/Manifest
@@ -1,4 +1,6 @@
+AUX tomsfastmath-0.13.1-export-fp_isprime_ex.patch 297 BLAKE2B 4147cc95152298cfbbd88416d11e298b95f574d7bf083900a2b0e72069764f4efcade6b074fb632abfb8f92a4e15b2e71de9a9578b2e65d0c63e4e258923a4b2 SHA512 33bb97d9a33d8bdb81a6a2df5b1727430a421bcf73df292b965663be532e30a4d815c332ee63b9790e04425ed80e58a30d9915a746cc265d98ad71a10da8bc34
AUX tomsfastmath-0.13.1-makefile-fix.patch 1703 BLAKE2B 2182f88b8569fac105eb179fdc7c10a7c9b7b17619a725c30d8374a2589f048e0ca0fe71ffb2431e058a264b104bc091deb800215a490399e722055b39adee0e SHA512 f5e5df821ecc7beb8684116294322dae8bf166bfbc7cf3d5262534e036f1d486854e58ad2c2da382b8f08aa6b9db71d91607289587c4247837bdfc3313ad5cff
DIST tfm-0.13.1.tar.xz 322684 BLAKE2B 393c0e0e018b199c9fc975ab3013466399ea337f520f4634649a9e61b2218b9a6b218d11212b535fc8bbd2bf40d8722fc413dc60756f1b8ff7c78da049765083 SHA512 84225fe81bbcd1df7e40ed0b8c8077d60612246a76f3149b672dfd1066eb0179262fa4f5a42ffd2034e60cb74cfd86e0b49139371971ebbb4f41a4ecebca2111
+EBUILD tomsfastmath-0.13.1-r1.ebuild 1704 BLAKE2B 93d8a2f6fffbe7fdb6f52e0898fb0f031cd41d1d482034bbf514b08274d90409aeabff00b7acff095d80afd742d96dbd891ea28e6cd61b7daf8b28ac054c9efb SHA512 b0b093c242383b53d993dbe0621d82626fdbec3a07478185512be34e40abaac758f3efe7d166abb95e39e4d8a0219cfaa69b221e4473da05f0ceb29afabd52dd
EBUILD tomsfastmath-0.13.1.ebuild 1643 BLAKE2B 15e096a6fee99486b8bab90053a461a1282aa70fa484c325f30c0ea7da3e24c883faf57c7c8d2597fe7e4231cb422a37b8b53d220a8689cc5db380f366b95922 SHA512 ecad188a7f91f5d376fa6786f4418c6c02d9e9b8a014eaee26535adebef20a26301b8cd2bfa39d56ad1dbf64d7fad275694f4780507c2457e261ea7722cb05d7
MISC metadata.xml 358 BLAKE2B 8dc827f40c0b51ca769622a56b5282b3265428fccc2330cb1732faa1ab03a6962057eccda6c0c0b58bfed3fa190e64c77fad4e6480cf65fe7ee251eb087422e8 SHA512 1473c76d0d4a743815de12895599cb3f9f97201f0eca1231af0f16600b5b795dcd8c4cba4847e3166004dc0b3319011bba2945dda510bd789d7b0ee066d96f88
diff --git a/dev-libs/tomsfastmath/files/tomsfastmath-0.13.1-export-fp_isprime_ex.patch b/dev-libs/tomsfastmath/files/tomsfastmath-0.13.1-export-fp_isprime_ex.patch
new file mode 100644
index 000000000000..627bf4b2f4d9
--- /dev/null
+++ b/dev-libs/tomsfastmath/files/tomsfastmath-0.13.1-export-fp_isprime_ex.patch
@@ -0,0 +1,13 @@
+Needed because libtomcrypt expects this symbol to be available
+https://github.com/libtom/tomsfastmath/commit/81530c207da8b3a43867da14df7d79d2cdf96978.patch
+--- a/libtfm.symbols
++++ b/libtfm.symbols
+@@ -16,6 +16,7 @@ fp_gcd
+ fp_ident
+ fp_invmod
+ fp_isprime
++fp_isprime_ex
+ fp_lcm
+ fp_lshd
+ fp_mod
+
diff --git a/dev-libs/tomsfastmath/tomsfastmath-0.13.1-r1.ebuild b/dev-libs/tomsfastmath/tomsfastmath-0.13.1-r1.ebuild
new file mode 100644
index 000000000000..738e6706e8c4
--- /dev/null
+++ b/dev-libs/tomsfastmath/tomsfastmath-0.13.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Fast public domain large integer arithmetic library"
+HOMEPAGE="https://www.libtom.net/TomsFastMath/
+ https://github.com/libtom/tomsfastmath"
+SRC_URI="https://github.com/libtom/tomsfastmath/releases/download/v${PV}/tfm-${PV}.tar.xz"
+LICENSE="Unlicense"
+
+# Current SONAME is 1
+# Please bump when the ABI changes upstream
+# Helpful site:
+# https://abi-laboratory.pro/index.php?view=timeline&l=tomsfastmath
+SLOT="0/1"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-fix.patch"
+ "${FILESDIR}/${PN}-0.13.1-export-fp_isprime_ex.patch"
+)
+
+_emake() {
+ # Standard boilerplate
+ # Upstream use homebrewed makefiles
+ # Best to use same args for all, for consistency,
+ # in case behaviour changes (v possible).
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ DESTDIR="${ED}" \
+ LIBPATH="/usr/$(get_libdir)" \
+ IGNORE_SPEED=1 \
+ "$@"
+}
+
+src_compile() {
+ _emake -f makefile.shared
+}
+
+src_test() {
+ _emake test_standalone stest rsatest
+
+ # We choose to be verbose during the test process
+ # because the output is quite repetitive with no
+ # clear demarcation b/t tests
+ local tests=( "test" "stest" "rsatest" )
+
+ local test
+ for test in "${tests[@]}"; do
+ einfo "Running test (${test})"
+ ./${test} || die "Test (${test}) failed"
+ einfo "Completed test (${test})"
+ done
+}
+
+src_install() {
+ _emake -f makefile.shared install
+
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+ # Same for static libs
+ find "${ED}" -name "*.a" -delete || die
+}