summaryrefslogtreecommitdiff
path: root/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'dev-libs/xalan-c/xalan-c-1.12-r2.ebuild')
-rw-r--r--dev-libs/xalan-c/xalan-c-1.12-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild b/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
new file mode 100644
index 000000000000..cd8b913943ee
--- /dev/null
+++ b/dev-libs/xalan-c/xalan-c-1.12-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN=${PN/-/_}
+DESCRIPTION="XSLT processor for transforming XML into HTML, text, or other XML types"
+HOMEPAGE="https://apache.github.io/xalan-c/"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/apache/xalan-c.git"
+
+ SLOT="0"
+else
+ inherit verify-sig
+ SRC_URI="
+ mirror://apache/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz
+ verify-sig? ( https://dlcdn.apache.org/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz.asc )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/apache-xalan-c.asc
+
+ SLOT="0/$(ver_cut 1-2)"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ BDEPEND="
+ verify-sig? ( sec-keys/openpgp-keys-apache-xalan-c )
+ "
+fi
+
+LICENSE="Apache-2.0"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/xerces-c[icu]
+"
+DEPEND="${RDEPEND}"
+BDEPEND+="
+ doc? ( app-doc/doxygen[dot] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-lto.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -Ddoxygen=$(usex doc)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc; then
+ docinto examples
+ dodoc -r samples/*/
+ fi
+}