summaryrefslogtreecommitdiff
path: root/dev-libs/xplc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/xplc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/xplc')
-rw-r--r--dev-libs/xplc/Manifest4
-rw-r--r--dev-libs/xplc/files/xplc-0.3.13-as-needed.patch22
-rw-r--r--dev-libs/xplc/metadata.xml12
-rw-r--r--dev-libs/xplc/xplc-0.3.13-r1.ebuild43
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/xplc/Manifest b/dev-libs/xplc/Manifest
new file mode 100644
index 000000000000..9117d5e2fb3d
--- /dev/null
+++ b/dev-libs/xplc/Manifest
@@ -0,0 +1,4 @@
+AUX xplc-0.3.13-as-needed.patch 561 BLAKE2B 585e22f03e0958581763d2f8d34731732b6008896690902e14393d14d3fbe89ad6d11ba39793eb44692d5ed818ea6df1c8bf6e32219def24d342ce4b9935fc30 SHA512 105fd3d6a2452ceace8c2de20f6ba16141e232126f9947c95b5ca6ba25a5a71f86eb40502ab895c1d78421cdb5888086f9e2bffc052ed800ad0a07a7db2c26ca
+DIST xplc-0.3.13.tar.gz 175431 BLAKE2B fb013a3e1a3c75b9de0ee8af43fce161811e5b99e5386a1ea5d0a19c36db3ec70d1cbad5d0848bb76857ecf37ee5b3006315a4663b1eb463b1915a8958ababbd SHA512 6969ed16c282589ddc285678e1c02016810f83c4c0fea373d8b7a72c97474e6cc21ca3f8f7a7a6aae814037dfae51c3a41bd39f13a67445552b6a7c1b698195d
+EBUILD xplc-0.3.13-r1.ebuild 1098 BLAKE2B b51dd5a7abd2ad038cbd1c4e1c037f4981c9612cb03c1e23aaadc4e36f9a42908233e246dfa28e1dd969f3b05feecc9f46d165e660ba7778a6bc46bcdafc9a7f SHA512 9769d4c9353d2914f94e94b9deee43495a8dfdc4a8b54e8d945c8914a01d6d5ec77112d9e4adf12fd96060900558647cc70d422beb61f1f95b78636cb03b5e7f
+MISC metadata.xml 413 BLAKE2B a01f1a22ed52b7e8e5ebd9f740e29413ab9da40a6a4ff6f5208df3b434296f3af7e4cfa68b01702b1c66bee5fb96004b2f77d48547e90b5d6c899e65d30e6fb7 SHA512 be0418b73ff322800a5908e278e31f27fdf77d986615885fe2b0b92ac2b23fa8a392736cf72bf91ff9c697bc89f2874a09ed4d9eb0127d3965a48272e516eac8
diff --git a/dev-libs/xplc/files/xplc-0.3.13-as-needed.patch b/dev-libs/xplc/files/xplc-0.3.13-as-needed.patch
new file mode 100644
index 000000000000..3e002db2ad00
--- /dev/null
+++ b/dev-libs/xplc/files/xplc-0.3.13-as-needed.patch
@@ -0,0 +1,22 @@
+--- config/rules.mk.orig 2006-05-06 19:28:46.000000000 +0200
++++ config/rules.mk 2006-05-06 19:28:53.000000000 +0200
+@@ -44,7 +44,7 @@
+ $(RANLIB) $@
+
+ %.so:
+- $(LINK.cc) $(SHARED) $^ -o $@
++ $(LINK.cc) $(SHARED) $^ $(LDLIBS) -o $@
+
+ %.dll:
+ $(LINK.cc) $(SHARED) $^ -o $@
+--- xplc/vars.mk.orig 2006-05-06 19:32:06.000000000 +0200
++++ xplc/vars.mk 2006-05-06 19:32:12.000000000 +0200
+@@ -32,7 +32,7 @@
+
+ ifneq ("$(enable_loader)", "no")
+ ifneq ("$(with_dlopen)", "no")
+-libxplc.so: LDFLAGS+=$(with_dlopen)
++libxplc.so: LDLIBS+=$(with_dlopen)
+ endif
+ endif
+
diff --git a/dev-libs/xplc/metadata.xml b/dev-libs/xplc/metadata.xml
new file mode 100644
index 000000000000..0a477f0bc1fb
--- /dev/null
+++ b/dev-libs/xplc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cpp@gentoo.org</email>
+ <name>Gentoo C++ Project</name>
+ </maintainer>
+ <longdescription>cross platform lightweight components library for C++</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xplc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/xplc/xplc-0.3.13-r1.ebuild b/dev-libs/xplc/xplc-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..3a4f3279917b
--- /dev/null
+++ b/dev-libs/xplc/xplc-0.3.13-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="cross platform lightweight components library for C++"
+HOMEPAGE="http://xplc.sourceforge.net"
+SRC_URI="mirror://sourceforge/xplc/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+DEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ #solve conflict with uuidgen utility installed by sys-fs/e2fsprogs (#116699)
+ sed -i -e "s/uuidgen/xplc-uuidgen/g" -e "s/uuidcdef/xplc-uuidcdef/g" \
+ uuid/{rules.mk,vars.mk} config/rules.mk \
+ uuid/bin/*.1 include/xplc/*.h && \
+ mv uuid/bin/uuidgen.1 uuid/bin/xplc-uuidgen.1 &&
+ mv uuid/bin/uuidgen.c uuid/bin/xplc-uuidgen.c ||
+ die "uuidgen rename failed"
+}
+
+src_test() {
+ make tests || die "at least one test has failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dosym /usr/lib/pkgconfig/${P}.pc /usr/lib/pkgconfig/${PN}.pc
+ dodoc LICENSE README NEWS CREDITS
+}