summaryrefslogtreecommitdiff
path: root/dev-libs/yaz/yaz-3.0.53.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/yaz/yaz-3.0.53.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/yaz/yaz-3.0.53.ebuild')
-rw-r--r--dev-libs/yaz/yaz-3.0.53.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-libs/yaz/yaz-3.0.53.ebuild b/dev-libs/yaz/yaz-3.0.53.ebuild
deleted file mode 100644
index 66af93b48754..000000000000
--- a/dev-libs/yaz/yaz-3.0.53.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils autotools
-
-DESCRIPTION="C/C++ toolkit for Z39.50v3 clients and servers"
-HOMEPAGE="http://www.indexdata.dk/yaz"
-SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc x86"
-IUSE="debug icu libressl tcpd ziffy"
-
-RDEPEND="dev-libs/libxml2
- dev-libs/libxslt
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- icu? ( dev-libs/icu:= )
- tcpd? ( sys-apps/tcp-wrappers )
- ziffy? ( net-libs/libpcap )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-lang/tcl:0
- >=sys-devel/libtool-2"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
- AT_M4DIR="m4" eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-static \
- --enable-shared \
- $(use_enable debug memdebug) \
- $(use_enable icu) \
- $(use_enable tcpd tcpd /usr)
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- local docdir="/usr/share/doc/${PF}"
- emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
-
- dodir ${docdir}/html
- mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
- mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
- rm -rf "${D}"/usr/share/doc/${PN}
-
- dodoc ChangeLog NEWS README
-}