summaryrefslogtreecommitdiff
path: root/dev-lisp/asdf-binary-locations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lisp/asdf-binary-locations
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lisp/asdf-binary-locations')
-rw-r--r--dev-lisp/asdf-binary-locations/Manifest5
-rw-r--r--dev-lisp/asdf-binary-locations/asdf-binary-locations-20061018.ebuild26
-rw-r--r--dev-lisp/asdf-binary-locations/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-lisp/asdf-binary-locations/Manifest b/dev-lisp/asdf-binary-locations/Manifest
new file mode 100644
index 000000000000..1a0de7df5f1b
--- /dev/null
+++ b/dev-lisp/asdf-binary-locations/Manifest
@@ -0,0 +1,5 @@
+DIST asdf-binary-locations_20061018.tar.gz 7504 SHA256 1ffc3473792cf383e7860551eaacb67fcf5a5421d371be2605ed3258f0f55f45 SHA512 3ce92f85763f65331debabd2fd6e2874e331552fda8a6657630b5696bacdb7282f00a5d98ecf2768087a7502a883582abc468de38a6d7aeef8ae0f03423653e0 WHIRLPOOL a9a7c61a267ad91ec4dec1dee7b5999c1e1b33685d244832595b4e4ee258e68882e0c9662139e7a3fdcbc9cedc568bf62eeb9f8ec94db3e7de4afc570e7827ec
+EBUILD asdf-binary-locations-20061018.ebuild 754 SHA256 69f26c2546728d3912b3cd1cf301dab4c30f9ebafffe31068bb6829c71298786 SHA512 0b125a4a324dd0de6ef1509530e9562eb80d525e494b26b01404e1b8054c614c8e7c9d8ecb66697388f3ffa66c2989c4fb8610a4d46642132046914086d17a86 WHIRLPOOL 9be957f6b65986a217672ab308b38b7551efdd145900ce173365752a8962c6668f71398bf02d5603637113d927962eca275301c219ea5bfd5ab3b6c803f2ee04
+MISC ChangeLog 2475 SHA256 551f751e34ef13f72ac9eb3bf032acc6245beb7ab6b27b95e3f82825fc5357c2 SHA512 1d17a507c88deecda1a2bb36c65fbf991df12d542b786b1f92504f3aa213e2ef39f03c9aaee023262e8ca1bfea5d3e01af235ee5f1665a5ae91a2d03ed7c7932 WHIRLPOOL 0138dd0df3e72a523ef1fb6f82d54b58892b5d933bcfa2c4a3d03806ffbc03436cb80e7dbb26d0365dedb5f0430fe882347f570df30e7a8af281f233a5fe61d9
+MISC ChangeLog-2015 2171 SHA256 3a55c5a0135f86e1c2594502ec7a006bea627760d33ea73822e8fa476ecff2d0 SHA512 d4c828f6f9027606acbdfacd2acf9106ff678039a8b46e0536954a62fb26407bd9b21fe7e45b98e71062b34b7a69f9fb5388673884bfe73d04aa646718e99ea3 WHIRLPOOL f2ced79615b35f9846d802f768ad54910dff017471b43e700c6dc7801bd687784f21fcba41ef560d504b33a7c16f7a2d105229b6f16223fc2f39f78ab34d4dfd
+MISC metadata.xml 261 SHA256 627a8fb846aff40f2f1e29e77040baa5b21fd7663158ab97b84012e0b5e2f742 SHA512 fb754c4ed3579db5dbe303197a05647b7cfab0a3fe47fd2140d5f77641be752d10ccf49a9c267406a0f3ba3dcda8831f778b9596d723f65aff10142bfad60d3d WHIRLPOOL 02fb9a9a64cd705025462ef7601b9b452954c62e41f57422a5a74e6e0c84695aca510635335b0cf35031dfbe75142c0feb06ce1ba4f2794c6230378d772c3ae3
diff --git a/dev-lisp/asdf-binary-locations/asdf-binary-locations-20061018.ebuild b/dev-lisp/asdf-binary-locations/asdf-binary-locations-20061018.ebuild
new file mode 100644
index 000000000000..4459b60001c5
--- /dev/null
+++ b/dev-lisp/asdf-binary-locations/asdf-binary-locations-20061018.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+inherit common-lisp
+
+DESCRIPTION="ASDF-Extension to specify where Common Lisp binaries (FASL files) should go"
+HOMEPAGE="http://common-lisp.net/project/cl-containers/asdf-binary-locations/"
+SRC_URI="http://common-lisp.net/project/portage-overlay/distfiles/${PN}_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lisp/asdf"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+CLPACKAGE=${PN}
+
+src_install() {
+ insinto $CLSOURCEROOT/$CLPACKAGE/dev
+ doins dev/*.lisp
+ common-lisp-install *.asd
+ common-lisp-system-symlink
+}
diff --git a/dev-lisp/asdf-binary-locations/metadata.xml b/dev-lisp/asdf-binary-locations/metadata.xml
new file mode 100644
index 000000000000..7ea645c67e72
--- /dev/null
+++ b/dev-lisp/asdf-binary-locations/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+</maintainer>
+</pkgmetadata>