summaryrefslogtreecommitdiff
path: root/dev-lua/lua-bit32
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-lua/lua-bit32
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-lua/lua-bit32')
-rw-r--r--dev-lua/lua-bit32/Manifest3
-rw-r--r--dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild48
-rw-r--r--dev-lua/lua-bit32/metadata.xml15
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-lua/lua-bit32/Manifest b/dev-lua/lua-bit32/Manifest
new file mode 100644
index 000000000000..df8ce5212b12
--- /dev/null
+++ b/dev-lua/lua-bit32/Manifest
@@ -0,0 +1,3 @@
+DIST lua-compat53-0.9.tar.gz 53599 BLAKE2B 7d9efe0afb49c40a68b1d6c28f975080b3331e07d0aa788e0f1f77d5c360504a5cac9cca4e6074b2c64aa7ad8934df3fe2609ff8009db52b046b2f639b670213 SHA512 bec15b6e95cb5cc775785515eba1f094e453059a0ba1eefa433d328b823378b7f48d9c7a34080ad77478cffb2008bead93418f809793afa6021e6046562acc58
+EBUILD lua-bit32-5.3.5.ebuild 1270 BLAKE2B cc69c0d34763589c78e81b954b33bedad6f0d69dc030e3cf8b05b4bd72f540b9e0e6a517713af1359bda3a397e631e36595e3ff2fb50435863c628cb08a71089 SHA512 3d389fc5e116909208994e1fb9e81f25269509137bafa7de385a7054a058068c79840fa64b92747fa1da10afb56119bcf4b5a3cbca3198c14ab3107c29be36a3
+MISC metadata.xml 485 BLAKE2B a5ec0e8d9920cd1f13a9211604ae5eb25db248a81b1d9469931347b77b1c64cee0fb34e54f93ab36611d35b79025966cc0ab13606084c81d1c7959a84bda045d SHA512 d79b3496b6d54ba350161c8b0aeee317df5053d334627ee9e8cdace0a699b4c9f1d9f58e5e391327baa89d4b6aa00fbccfda5b40718f7e852d4e21dc8da3cf27
diff --git a/dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild b/dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild
new file mode 100644
index 000000000000..82297b4fe6ab
--- /dev/null
+++ b/dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Backported Lua bit manipulation library"
+HOMEPAGE="https://github.com/keplerproject/lua-compat-5.3"
+# Wierd upstream version descisions...
+# Result tarball may be reused for future lua-compat53 package
+LUA_COMPAT_V=0.9
+SRC_URI="https://github.com/keplerproject/lua-compat-5.3/archive/v${LUA_COMPAT_V}.tar.gz -> lua-compat53-${LUA_COMPAT_V}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+# Strictly for lua 5.1
+DEPEND="dev-lang/lua:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/lua-compat-5.3-${LUA_COMPAT_V}"
+
+src_compile() {
+ # TODO maybe sometime there will be luarocks eclass...
+ compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -I/usr/include -c lbitlib.c -o lbitlib.o -DLUA_COMPAT_BITLIB -Ic-api"
+ einfo "${compile}"
+ eval "${compile}" || die
+
+ link="$(tc-getCC) -shared ${LDFLAGS} -o bit32.so lbitlib.o"
+ einfo "${link}"
+ eval "${link}" || die
+}
+
+src_test() {
+ LUA_CPATH=./?.so lua tests/test-bit32.lua || die
+}
+
+src_install() {
+ exeinto $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)
+ doexe bit32.so
+ dodoc README.md
+}
diff --git a/dev-lua/lua-bit32/metadata.xml b/dev-lua/lua-bit32/metadata.xml
new file mode 100644
index 000000000000..32feba463055
--- /dev/null
+++ b/dev-lua/lua-bit32/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keplerproject/lua-compat-5.3</remote-id>
+ </upstream>
+</pkgmetadata>