summaryrefslogtreecommitdiff
path: root/dev-lua/lua-term/lua-term-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lua/lua-term/lua-term-0.3.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/lua-term/lua-term-0.3.ebuild')
-rw-r--r--dev-lua/lua-term/lua-term-0.3.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-lua/lua-term/lua-term-0.3.ebuild b/dev-lua/lua-term/lua-term-0.3.ebuild
deleted file mode 100644
index 2bf85543e545..000000000000
--- a/dev-lua/lua-term/lua-term-0.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-# Yes, upstream used different version numbers.
-# The rockspec version number is 0.3, but the version associated with
-# the tarball is 0.03.
-MY_PV=0.03
-
-DESCRIPTION="Terminal functions for Lua"
-HOMEPAGE="https://github.com/hoelzro/lua-term"
-SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE=""
-
-COMMON_DEPEND=">=dev-lang/lua-5.1:="
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_compile() {
- echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
- -o core.so core.c"
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
- -o core.so core.c || die
-}
-
-src_install() {
- exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
- doexe core.so
- insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
-doins -r term
-}