summaryrefslogtreecommitdiff
path: root/dev-lua/lua-term/lua-term-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-lua/lua-term/lua-term-0.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lua/lua-term/lua-term-0.3.ebuild')
-rw-r--r--dev-lua/lua-term/lua-term-0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lua/lua-term/lua-term-0.3.ebuild b/dev-lua/lua-term/lua-term-0.3.ebuild
new file mode 100644
index 000000000000..2bf85543e545
--- /dev/null
+++ b/dev-lua/lua-term/lua-term-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+# Yes, upstream used different version numbers.
+# The rockspec version number is 0.3, but the version associated with
+# the tarball is 0.03.
+MY_PV=0.03
+
+DESCRIPTION="Terminal functions for Lua"
+HOMEPAGE="https://github.com/hoelzro/lua-term"
+SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o core.so core.c"
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o core.so core.c || die
+}
+
+src_install() {
+ exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
+ doexe core.so
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+doins -r term
+}