summaryrefslogtreecommitdiff
path: root/dev-lua/luassert/luassert-1.7.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lua/luassert/luassert-1.7.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lua/luassert/luassert-1.7.10.ebuild')
-rw-r--r--dev-lua/luassert/luassert-1.7.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lua/luassert/luassert-1.7.10.ebuild b/dev-lua/luassert/luassert-1.7.10.ebuild
new file mode 100644
index 000000000000..cc60c96aaf5c
--- /dev/null
+++ b/dev-lua/luassert/luassert-1.7.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua Assertions Extension"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/luassert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit test"
+
+CDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:2 )"
+RDEPEND="${CDEPEND}
+ >=dev-lua/say-1.2_p1[luajit=]"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-lua/busted )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_test() {
+ busted -o gtest || die
+}
+
+src_install() {
+ local instdir
+ instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"/${PN}
+ insinto "${instdir#${EPREFIX}}"
+ doins -r src/*
+ einstalldocs
+}