summaryrefslogtreecommitdiff
path: root/dev-lua/say/say-1.3_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-lua/say/say-1.3_p1-r1.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-lua/say/say-1.3_p1-r1.ebuild')
-rw-r--r--dev-lua/say/say-1.3_p1-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-lua/say/say-1.3_p1-r1.ebuild b/dev-lua/say/say-1.3_p1-r1.ebuild
deleted file mode 100644
index b73175d9b818..000000000000
--- a/dev-lua/say/say-1.3_p1-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-MY_PV=1.3-1
-
-inherit toolchain-funcs
-
-DESCRIPTION="Lua String Hashing/Indexing Library"
-HOMEPAGE="http://olivinelabs.com/busted/"
-SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="luajit test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1:0= )
- luajit? ( dev-lang/luajit:2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-lua/busted )"
-
-DOCS=( CONTRIBUTING.md README.md )
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_test() {
- busted -o gtest || die
-}
-
-src_install() {
- local instdir
- instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"/${PN}
- insinto "${instdir#${EPREFIX}}"
- doins src/init.lua
- einstalldocs
-}