summaryrefslogtreecommitdiff
path: root/dev-ml/alcotest/alcotest-1.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
commitc9388864702fdd7b0b56c049eddb41bdb9054dcb (patch)
tree3595822471cd11e6f9f92565ab81ab9c5ee39c3f /dev-ml/alcotest/alcotest-1.6.0-r1.ebuild
parenta41f630aea0b4b71a6c9a088571f1eaaf8413d53 (diff)
gentoo auto-resync : 30:10:2022 - 15:03:33
Diffstat (limited to 'dev-ml/alcotest/alcotest-1.6.0-r1.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-1.6.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/alcotest/alcotest-1.6.0-r1.ebuild b/dev-ml/alcotest/alcotest-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..f241b544a2a3
--- /dev/null
+++ b/dev-ml/alcotest/alcotest-1.6.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-ml/dune-2.8:=
+ dev-ml/astring:=
+ dev-ml/async_kernel:=
+ dev-ml/async:=
+ >=dev-ml/async_unix-0.15.0:=
+ dev-ml/base:=
+ dev-ml/cmdliner:=
+ >=dev-ml/core-0.15.0:=
+ >=dev-ml/core_unix-0.15.0:=
+ dev-ml/duration:=
+ >=dev-ml/fmt-0.8.9:=
+ dev-ml/lwt:=
+ dev-ml/mirage-clock:=
+ dev-ml/re:=
+ dev-ml/result:=
+ dev-ml/logs:=
+ dev-ml/uutf:=
+ dev-ml/uuidm:=
+"
+DEPEND="${RDEPEND}"