summaryrefslogtreecommitdiff
path: root/dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild')
-rw-r--r--dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild b/dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild
new file mode 100644
index 000000000000..40d81a856586
--- /dev/null
+++ b/dev-ml/angstrom-unix/angstrom-unix-0.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Parser combinators built for speed and memory efficiency"
+HOMEPAGE="https://github.com/inhabitedtype/angstrom"
+SRC_URI="https://github.com/inhabitedtype/angstrom/archive/${PV}.tar.gz -> angstrom-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/angstrom:="
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder"
+
+S="${WORKDIR}/angstrom-${PV}"
+
+src_compile() {
+ jbuilder build -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN}
+}