summaryrefslogtreecommitdiff
path: root/dev-ml/base/base-0.14.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 01:36:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 01:36:49 +0000
commit65e0298c5630af19b2b181c2dd143bb47aa54231 (patch)
tree4dfaf06d77acbaff8f85b3d5f9848b01ab7fe236 /dev-ml/base/base-0.14.0-r2.ebuild
parentd5f4fe0e51ffa8d74055615bc4f0e2e950b5dadb (diff)
gentoo auto-resync : 30:12:2023 - 01:36:49
Diffstat (limited to 'dev-ml/base/base-0.14.0-r2.ebuild')
-rw-r--r--dev-ml/base/base-0.14.0-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/base/base-0.14.0-r2.ebuild b/dev-ml/base/base-0.14.0-r2.ebuild
new file mode 100644
index 000000000000..b297736ade18
--- /dev/null
+++ b/dev-ml/base/base-0.14.0-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard library for OCaml"
+HOMEPAGE="https://github.com/janestreet/base"
+SRC_URI="https://github.com/janestreet/base/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ <dev-lang/ocaml-4.12
+ >=dev-ml/sexplib0-0.14.0:=[ocamlopt?] <dev-ml/sexplib0-0.15.0:=
+ dev-ml/dune-configurator:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"