summaryrefslogtreecommitdiff
path: root/dev-ml/base/base-0.16.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-01 01:44:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-01 01:44:20 +0100
commit7714c84b341b3c783197e342fda2df5e579ac91f (patch)
treee36f0bc3e2f90b502c7a34747e555d4ec8c71f02 /dev-ml/base/base-0.16.1-r1.ebuild
parentb7efdd771aad99c9a6509a5f85a80a1f7cfd55f3 (diff)
gentoo auto-resync : 01:07:2023 - 01:44:19
Diffstat (limited to 'dev-ml/base/base-0.16.1-r1.ebuild')
-rw-r--r--dev-ml/base/base-0.16.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/base/base-0.16.1-r1.ebuild b/dev-ml/base/base-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..500f481d48ff
--- /dev/null
+++ b/dev-ml/base/base-0.16.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard library for OCaml"
+HOMEPAGE="https://github.com/janestreet/base"
+SRC_URI="https://github.com/janestreet/base/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14.0
+ =dev-ml/sexplib0-0.16*:=
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}"