summaryrefslogtreecommitdiff
path: root/dev-ml/base/base-0.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/base/base-0.9.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/base/base-0.9.2.ebuild')
-rw-r--r--dev-ml/base/base-0.9.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/base/base-0.9.2.ebuild b/dev-ml/base/base-0.9.2.ebuild
new file mode 100644
index 000000000000..b6a07e3d5965
--- /dev/null
+++ b/dev-ml/base/base-0.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Standard library for OCaml"
+HOMEPAGE="https://github.com/janestreet/base"
+SRC_URI="https://github.com/janestreet/base/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ <dev-ml/sexplib-100
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc ROADMAP.md README.org
+}