summaryrefslogtreecommitdiff
path: root/dev-ml/camlbz2/camlbz2-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/camlbz2/camlbz2-0.6.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/camlbz2/camlbz2-0.6.0.ebuild')
-rw-r--r--dev-ml/camlbz2/camlbz2-0.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/camlbz2/camlbz2-0.6.0.ebuild b/dev-ml/camlbz2/camlbz2-0.6.0.ebuild
new file mode 100644
index 000000000000..15884ba324e3
--- /dev/null
+++ b/dev-ml/camlbz2/camlbz2-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml bindings for libbz (AKA, bzip2)"
+HOMEPAGE="http://camlbz2.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/72/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/bzip2
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${OCAMLFIND_DESTDIR}" install
+ dodoc ChangeLog README ROADMAP BUGS
+ use doc && dohtml doc/*
+}