summaryrefslogtreecommitdiff
path: root/dev-ml/camlpdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
commit7166f3a0a0b7886d340010458d0b130013cb9989 (patch)
tree3ff502007dde9dba943a004a3bf201ae4e0787bd /dev-ml/camlpdf
parent345c02ca33341652116ddec6705530223af2de85 (diff)
gentoo auto-resync : 28:08:2024 - 12:00:19
Diffstat (limited to 'dev-ml/camlpdf')
-rw-r--r--dev-ml/camlpdf/Manifest4
-rw-r--r--dev-ml/camlpdf/camlpdf-2.7.1.ebuild36
-rw-r--r--dev-ml/camlpdf/metadata.xml9
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-ml/camlpdf/Manifest b/dev-ml/camlpdf/Manifest
index 1ed0551dd5c6..effa9c50aca2 100644
--- a/dev-ml/camlpdf/Manifest
+++ b/dev-ml/camlpdf/Manifest
@@ -1,3 +1,5 @@
DIST camlpdf-2.3.1.tar.gz 601531 BLAKE2B 9534baf9165e7dc48ae37a3fcaabb236e437845ef4e0a60a1c08874a2b240c9b1e96de5bbd6028a3ca87992221773dea34c31b0fa24e9c143632756954baf132 SHA512 0b8d91b6090221f996aee52f22f153a4b74cb85a127bbd5f84492ede8a0a581971a2349281b3879d6c37f4d5d267da583e7e8871372d97a3d636abc3231cb007
+DIST camlpdf-2.7.1.tar.gz 841886 BLAKE2B 30215949fab2517e00cf520ef4f79a6fbf49173e7e2643ac1a47d0dd945063908de2928f7181d2182ad4fe51945bb3f6a89a54aa236a889ea392cd126ef856c8 SHA512 2480a282a6ce09444ed14a3f41561375ecf7e3c57f7559a48ad9791d9f824e59820bfd39aa36910ff6bdc9b160cef76ab90dbbfe628c836c3f5c5081dfd5e452
EBUILD camlpdf-2.3.1.ebuild 792 BLAKE2B ed804c71e8eed524e0b119f39865bc57b28f736854066f47daa5b773a793a302b692e65d6273e2e77f9908aa0f0be0f97c2eec7987a49b824d24cf87c493fbb4 SHA512 e59b4c2de92c39d6f115b4d4487a90aadebf3fea79f8921c59ed40594c2c5151fe3f3928df8a0a4006cb01e2d76271df58a55a6779529ffb2cef91bececa32d5
-MISC metadata.xml 260 BLAKE2B f53ea63be92b316155a236a1e56ff65fe1d4962d01313f3c6aa409a7887540aa9cc64e23ecee6f28f1d84a1ed51e13350e6d29933c57c7cad9fb6922458ee16e SHA512 905b0890c11d2e2ada5fc968e4f307d028bfe5ebd86af6b810f34c7957fb5bf474ec7530da565fa8d110245880b31d67e4495e6eb8da2c05d5b1365902917dcc
+EBUILD camlpdf-2.7.1.ebuild 802 BLAKE2B ac9c521f77ce083ecbf28945bb9cd7eea82d884fa6b892c2ebfb39fe9dcdf9ee35dafcb157d3a370e18044ac1c339d868a3d76740118eb382322c8cb1e036a67 SHA512 9be50ec85486928ad5d76f39f5cf31942d181c0ac55208de579c941f260ba35a2dceb772f0f3a4c9a1b2eef16d56cd4432f1191691081f363556b0f2f77f8ef3
+MISC metadata.xml 503 BLAKE2B c08f43e3c7a1c07183d22bda7df8c45a4c49c6c6f5d5edde28820bf5a92582276e10cfd2bd957acd04a08f64a4f613a6bb2da45ea3c315e1b55b5bd94358cd75 SHA512 7d778b3a9aee27e53b2138ec99f200e96253f0455ba66a0d7173765c6a556260ca70b6d234123ecf1dd65baae3fa03499c59e73502c2021d0d1abaf4971157c1
diff --git a/dev-ml/camlpdf/camlpdf-2.7.1.ebuild b/dev-ml/camlpdf/camlpdf-2.7.1.ebuild
new file mode 100644
index 000000000000..1aada1b8ee02
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception LGPL-2.1+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dodoc -r doc/camlpdf/html
+ fi
+
+ use examples && dodoc -r examples
+}
diff --git a/dev-ml/camlpdf/metadata.xml b/dev-ml/camlpdf/metadata.xml
index fce9dcd784fb..930714b49b52 100644
--- a/dev-ml/camlpdf/metadata.xml
+++ b/dev-ml/camlpdf/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>ivan.lloro.boada@gmail.com</email>
+ <name>Ivan Lloro</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">johnwhitington/camlpdf</remote-id>
</upstream>