summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip/camlzip-1.07.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-ml/camlzip/camlzip-1.07.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-ml/camlzip/camlzip-1.07.ebuild')
-rw-r--r--dev-ml/camlzip/camlzip-1.07.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-ml/camlzip/camlzip-1.07.ebuild b/dev-ml/camlzip/camlzip-1.07.ebuild
index 547fe00d0c83..448875803b1b 100644
--- a/dev-ml/camlzip/camlzip-1.07.ebuild
+++ b/dev-ml/camlzip/camlzip-1.07.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit findlib eutils versionator
-
-IUSE="+ocamlopt"
+inherit findlib
DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
HOMEPAGE="https://github.com/xavierleroy/camlzip"
-SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(delete_all_version_separators ${PV}).tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
SLOT="1/${PV}"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
RDEPEND=">=dev-lang/ocaml-4.05:=[ocamlopt?]
- >=sys-libs/zlib-1.1.3"
+ >=sys-libs/zlib-1.1.3"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-rel$(delete_all_version_separators ${PV})"
-
src_compile() {
emake all
if use ocamlopt; then
@@ -30,6 +28,7 @@ src_compile() {
src_install() {
findlib_src_preinst
+
emake DESTDIR="${D}" install-findlib
dodoc README Changes