summaryrefslogtreecommitdiff
path: root/dev-ml/camomile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/camomile
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/camomile')
-rw-r--r--dev-ml/camomile/Manifest4
-rw-r--r--dev-ml/camomile/camomile-0.8.5-r1.ebuild41
-rw-r--r--dev-ml/camomile/files/ocaml405.patch40
-rw-r--r--dev-ml/camomile/metadata.xml11
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-ml/camomile/Manifest b/dev-ml/camomile/Manifest
new file mode 100644
index 000000000000..fef4b1f7e704
--- /dev/null
+++ b/dev-ml/camomile/Manifest
@@ -0,0 +1,4 @@
+AUX ocaml405.patch 1469 BLAKE2B 06ef619b7dd82b584e192eea1818de0b95e5005a9c5492bd2c8ee4430728a6577b0f125e63ba483d40593f08ec7e885e279bbf815896d1b36d4177910a95f9bf SHA512 b8951a401ee8b4c4e49e4a144c6ea5e0cc3c50ab62c95f34a4766fd46a4a93d9eea13c5d30b00eabaee00d70a3cc82a8251d110e622e00c623c8467867cc95ba
+DIST camomile-0.8.5.tar.bz2 2607084 BLAKE2B 5e0ff51cdd6d7ce41ee024189a793f3d3e4bec1bd9849e7c01d2722ff22ca2cb5f0d5bd5f95820e741469ebda2996edf3611827535df5fe095d3f6617ecfdd42 SHA512 ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014
+EBUILD camomile-0.8.5-r1.ebuild 888 BLAKE2B 3b08a60d1798ce21950e2ded5212d28f39792710024e8cb3a2fd882639ae1cff6f1eee635cabe5cafeea018f59ee5e65468597303075a0a0e7f7966a4784ea56 SHA512 8adaa7baea01f24cec23a0ef28efd92a33d910a2b9eb3b3920fe2f180ef397198b9055f4f8880c5dab793295a59238fa13488e8c5f50b0fabfbabda97166f2c6
+MISC metadata.xml 339 BLAKE2B 29e7f7ac895463cf693b7c3cad7e0b767126b43c1b11162ca6718f2561f74e466502e5a136a9fa5b7b6312505e2b937590488185a1b76de22bd6bc980dba295d SHA512 32caf2bcfc2f9481faf5d86ba612d0da5887f767236aee93f5c8c647044f38e31f0dac30c63566c131be42037d22511147c8eedd2832082d731fe19a533964d0
diff --git a/dev-ml/camomile/camomile-0.8.5-r1.ebuild b/dev-ml/camomile/camomile-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..68d9d15dcc3e
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="https://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="https://github.com/yoriyuki/Camomile/releases/download/rel-${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.05_beta' && epatch "${FILESDIR}/ocaml405.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}
diff --git a/dev-ml/camomile/files/ocaml405.patch b/dev-ml/camomile/files/ocaml405.patch
new file mode 100644
index 000000000000..3fec6955a27c
--- /dev/null
+++ b/dev-ml/camomile/files/ocaml405.patch
@@ -0,0 +1,40 @@
+commit 0fa0a19f15998e89e4b04150dd74529bbd406f42
+Author: Gabriel Scherer <gabriel.scherer@gmail.com>
+Date: Fri Feb 24 22:30:23 2017 -0500
+
+ 4.05 compatibility: use explicit module signatures
+
+ In 4.05, checking for non-generalizable inference variable ('_a)
+ (forbidden in toplevel modules and functors) happens before checking
+ the .ml file against the .mli signature, so non-generalizable
+ variables that were previously resolved through the .mli constraint
+ are now underspecified and result in a compilation failure
+ (see MPR#7414, GPR#929). This commit adds enough annotations to avoid
+ such underspecified variables in functors.
+
+diff --git a/Camomile/internal/unimap.ml b/Camomile/internal/unimap.ml
+index b6fdbde..6a7cc30 100644
+--- a/Camomile/internal/unimap.ml
++++ b/Camomile/internal/unimap.ml
+@@ -58,7 +58,7 @@ val of_name : string -> t
+ end
+
+
+-module Make (Config : ConfigInt.Type) = struct
++module Make (Config : ConfigInt.Type) : Type = struct
+
+ type mapping = {no_char : int; tbl : Tbl31.Bytes.t}
+
+diff --git a/Camomile/public/uCharInfo.ml b/Camomile/public/uCharInfo.ml
+index 69bf141..6a0337a 100644
+--- a/Camomile/public/uCharInfo.ml
++++ b/Camomile/public/uCharInfo.ml
+@@ -298,7 +298,7 @@ val load_composition_exclusion_tbl : unit -> UCharTbl.Bool.t
+
+ end
+
+-module Make (Config : ConfigInt.Type) = struct
++module Make (Config : ConfigInt.Type) : Type = struct
+ include Unidata.Make(Config)
+
+ (* General category *)
diff --git a/dev-ml/camomile/metadata.xml b/dev-ml/camomile/metadata.xml
new file mode 100644
index 000000000000..82a7e9775c14
--- /dev/null
+++ b/dev-ml/camomile/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">yoriyuki/Camomile</remote-id>
+ </upstream>
+</pkgmetadata>