summaryrefslogtreecommitdiff
path: root/dev-ml/capnp-ocaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/capnp-ocaml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/capnp-ocaml')
-rw-r--r--dev-ml/capnp-ocaml/Manifest5
-rw-r--r--dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild36
-rw-r--r--dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild36
-rw-r--r--dev-ml/capnp-ocaml/metadata.xml11
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-ml/capnp-ocaml/Manifest b/dev-ml/capnp-ocaml/Manifest
new file mode 100644
index 000000000000..eca5434180b8
--- /dev/null
+++ b/dev-ml/capnp-ocaml/Manifest
@@ -0,0 +1,5 @@
+DIST capnp-ocaml-3.0.0.tar.gz 140985 BLAKE2B 00d9bfec72ca60ae5b17730248554b5d5d7b0b85d007cc0dc3332043416125b1931e3d92b3d17ce12b40ae4094ff4ff212aaa327332588c6d00a853e31dea6a4 SHA512 5cdf678fa80e67c552f60123f1d04eb5facad81e6c29661c2234c06bbcb98312d1eba96f81f3e747fef0b4de986aff07b69aafcbfde60873ba40452a66d75075
+DIST capnp-ocaml-3.1.0.tar.gz 141189 BLAKE2B 503fa710f4940e4235b04d5090b29d5d43a351c057b6ec0dd07827c7b0f906261bf2ec3c8365b866190a6e202b9234e8b648d9846d8aaed8bb40b8601f8d9bcf SHA512 d3a24800ee334d5d0506a9b9f2db10994e475b205e347ae606d4f963cd846c7ab2ed8f60505495509cf2f3444c46b8aefe0501c6803874b5659b8b6429506b77
+EBUILD capnp-ocaml-3.0.0.ebuild 705 BLAKE2B 2552bc64b6342b4a730e73fb7c71316329b02e9791da3f55ddd6aa4138d99d1caae76fac8984bb1bf15186f329534d9938b638304517030086fceebbccf269e3 SHA512 0cf3b6440cc4db39eee8a9486b0e385af018713b31ca04d0e90e7e7748272a721016abf90d6684dee7c95618ffa90775c05b96aa575e5c8b7909aece0620e4e4
+EBUILD capnp-ocaml-3.1.0.ebuild 705 BLAKE2B 2552bc64b6342b4a730e73fb7c71316329b02e9791da3f55ddd6aa4138d99d1caae76fac8984bb1bf15186f329534d9938b638304517030086fceebbccf269e3 SHA512 0cf3b6440cc4db39eee8a9486b0e385af018713b31ca04d0e90e7e7748272a721016abf90d6684dee7c95618ffa90775c05b96aa575e5c8b7909aece0620e4e4
+MISC metadata.xml 331 BLAKE2B 4172955d0af56dceca74d19fe149a1c6231225d494de2bb026700940d246dc75a65d7907651d7f585e0a9c40a0d14a79f3751b629099b7ea366bc2a4434d5164 SHA512 c105113be48774c0cb057e038ab129c19290f9a46ef0b1de656905e8c2a5f42570381f691eafb23a99b2797126dbf95dee5381cd8826bb32d38fc56bb40c7268
diff --git a/dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild b/dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild
new file mode 100644
index 000000000000..4d060a2a99a2
--- /dev/null
+++ b/dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="OCaml code generator plugin for the Cap'n Proto serialization framework"
+HOMEPAGE="https://github.com/pelzlpj/capnp-ocaml"
+SRC_URI="https://github.com/pelzlpj/capnp-ocaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/core_kernel:=
+ dev-ml/ocaml-extunix:=
+ dev-ml/ocplib-endian:=
+ dev-ml/res:=
+ dev-ml/ocaml-uint:=
+ dev-libs/capnproto:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/core:= dev-ml/ounit )
+ dev-ml/jbuilder
+"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ opam_src_install capnp
+}
diff --git a/dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild b/dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild
new file mode 100644
index 000000000000..4d060a2a99a2
--- /dev/null
+++ b/dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="OCaml code generator plugin for the Cap'n Proto serialization framework"
+HOMEPAGE="https://github.com/pelzlpj/capnp-ocaml"
+SRC_URI="https://github.com/pelzlpj/capnp-ocaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/core_kernel:=
+ dev-ml/ocaml-extunix:=
+ dev-ml/ocplib-endian:=
+ dev-ml/res:=
+ dev-ml/ocaml-uint:=
+ dev-libs/capnproto:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/core:= dev-ml/ounit )
+ dev-ml/jbuilder
+"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ opam_src_install capnp
+}
diff --git a/dev-ml/capnp-ocaml/metadata.xml b/dev-ml/capnp-ocaml/metadata.xml
new file mode 100644
index 000000000000..d4602eeb2f4d
--- /dev/null
+++ b/dev-ml/capnp-ocaml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pelzlpj/capnp-ocaml</remote-id>
+ </upstream>
+</pkgmetadata>