summaryrefslogtreecommitdiff
path: root/dev-ml/core/core-0.14.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/core/core-0.14.0-r4.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/core/core-0.14.0-r4.ebuild')
-rw-r--r--dev-ml/core/core-0.14.0-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.14.0-r4.ebuild b/dev-ml/core/core-0.14.0-r4.ebuild
new file mode 100644
index 000000000000..f6d81379f69f
--- /dev/null
+++ b/dev-ml/core/core-0.14.0-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+# TODO: Wants quickcheck_deprecated?
+RESTRICT="test"
+
+RDEPEND="
+ <dev-lang/ocaml-4.12
+ dev-ml/base:=
+ <dev-ml/core_kernel-0.15:=
+ <dev-ml/jst-config-0.15:=
+ <dev-ml/ppx_jane-0.15:=
+ <dev-ml/sexplib-0.15:=
+ dev-ml/spawn:=
+ dev-ml/stdio:=
+ dev-ml/timezone:=
+"
+DEPEND="${RDEPEND}"