summaryrefslogtreecommitdiff
path: root/dev-ml/core/core-0.15.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 02:53:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 02:53:24 +0000
commitb8ec9071f5d20d8518b02d0077428b2c9f88861b (patch)
tree6214c0d63a2bd5ae464941924a90f415687fa63c /dev-ml/core/core-0.15.1-r1.ebuild
parentbdf6e70da7a28f45617c02a251bb6b3844202bc5 (diff)
gentoo auto-resync : 29:01:2023 - 02:53:24
Diffstat (limited to 'dev-ml/core/core-0.15.1-r1.ebuild')
-rw-r--r--dev-ml/core/core-0.15.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.15.1-r1.ebuild b/dev-ml/core/core-0.15.1-r1.ebuild
new file mode 100644
index 000000000000..cb9cceda4135
--- /dev/null
+++ b/dev-ml/core/core-0.15.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+# TODO: Wants quickcheck_deprecated?
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.11
+ >=dev-ml/base-0.15.1:${SLOT}
+ dev-ml/base_bigstring:${SLOT}
+ dev-ml/base_quickcheck:=
+ dev-ml/bin_prot:=
+ dev-ml/ppxlib:=
+ dev-ml/ppx_bin_prot:=
+ dev-ml/ppx_bench:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_disable_unused_warnings:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_fixed_literal:=
+ dev-ml/ppx_let:=
+ dev-ml/ppx_log:=
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/ppx_module_timer:=
+ dev-ml/ppx_optional:=
+ dev-ml/ppx_pipebang:=
+ dev-ml/ppx_sexp_message:=
+ dev-ml/ppx_sexp_value:=
+ dev-ml/ppx_stable:=
+ dev-ml/ppx_string:=
+ dev-ml/ppx_ignore_instrumentation:=
+ dev-ml/typerep:=
+"
+DEPEND="${RDEPEND}"