summaryrefslogtreecommitdiff
path: root/dev-ml/core/core-0.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
commit8164a4e49d69b936f2d820456e48468dc0e241ad (patch)
tree72c381896b721d4947b8f65f0cadceef779b99ae /dev-ml/core/core-0.16.1.ebuild
parentc3ec60d8953748433a04137e04480e9c1a36ed4c (diff)
gentoo auto-resync : 02:07:2023 - 11:30:05
Diffstat (limited to 'dev-ml/core/core-0.16.1.ebuild')
-rw-r--r--dev-ml/core/core-0.16.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.16.1.ebuild b/dev-ml/core/core-0.16.1.ebuild
new file mode 100644
index 000000000000..dc2f2c901b50
--- /dev/null
+++ b/dev-ml/core/core-0.16.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ dev-ml/base_bigstring:${SLOT}
+ dev-ml/base_quickcheck:${SLOT}
+ dev-ml/bin_prot:${SLOT}
+ dev-ml/ppxlib:=
+ dev-ml/ppx_bin_prot:=
+ dev-ml/ppx_bench:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_disable_unused_warnings:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_fixed_literal:=
+ dev-ml/ppx_let:=
+ dev-ml/ppx_log:=
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/ppx_module_timer:=
+ dev-ml/ppx_optional:=
+ dev-ml/ppx_pipebang:=
+ dev-ml/ppx_sexp_message:${SLOT}
+ dev-ml/ppx_sexp_value:=
+ dev-ml/ppx_stable:=
+ dev-ml/ppx_string:=
+ dev-ml/ppx_ignore_instrumentation:=
+ dev-ml/typerep:${SLOT}
+"
+DEPEND="${RDEPEND}"