summaryrefslogtreecommitdiff
path: root/dev-ml/core_bench/core_bench-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
commit5e0a5ca921524f8859808527a57655eec16efa52 (patch)
tree7c58411b1e81478df4e20082a6adec2553c24c5c /dev-ml/core_bench/core_bench-0.16.0.ebuild
parent4c16e0a214824f15f09396e359db4f1f5c086fec (diff)
gentoo auto-resync : 18:07:2023 - 00:58:24
Diffstat (limited to 'dev-ml/core_bench/core_bench-0.16.0.ebuild')
-rw-r--r--dev-ml/core_bench/core_bench-0.16.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/core_bench/core_bench-0.16.0.ebuild b/dev-ml/core_bench/core_bench-0.16.0.ebuild
new file mode 100644
index 000000000000..4e7da1d6882d
--- /dev/null
+++ b/dev-ml/core_bench/core_bench-0.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Micro-benchmarking library for OCaml"
+HOMEPAGE="https://github.com/janestreet/core_bench"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/core:${SLOT}
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/core_unix:${SLOT}
+ dev-ml/ppx_compare:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/ppx_let:${SLOT}
+ dev-ml/textutils:${SLOT}
+"
+RDEPEND="${DEPEND}"